2

I have a systemd service and some ExecStartPost scripts. Sometimes these scripts may take a long time. While these scripts are executing, service is in "activating" state. Is there any way to set an activation timeout? E.g. if service is activating more than a minute, restart the service.

Any sugestions? Thanks in advance!

2

TimeoutStartSec parameter of systemd service Unit solves the problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.