1

I have 3 nfs mounts that used to work but don't work from fstab any longer but do work on other servers.

Also if I mount manually from said server they work

mount Server:/backup01  /backup01

but in fstab, with flags, it is not working:

Server:/nas/stage /u00/stage      nfs     rw,bg,hard,nointr,rsize=32768,wsize=32768,tcp,vers=3,timeo=600,actimeo=0 0 0
Server:/backup    /u00/backup     nfs     rw,bg,hard,intr,rsize=32768,wsize=32768,tcp,noac,nfsvers=3,timeo=600    0 0
Server:/backup01  /backup01       nfs     rw,bg,hard,intr,rsize=32768,wsize=32768,tcp,noac,nfsvers=3,timeo=600    0 0

Also note it fails silently.

Any ideas would be much appreciated.

Update: I went through each option and found the issue is with TCP option. Im not sure why yet as that option works on all other servers. Will keep looking but if someone can save me sometime and shed any light on why the TCP option wouldnt be working that would be great :)

7
  • It doesn't fail silently, it runs in background. NFS manual says If the bg option is in effect, the mount command backgrounds itself and continues to attempt the specified mount request.
    – andcoz
    Mar 24, 2017 at 8:06
  • There is any clue in logs? /var/log/messages'd contain some information on the mount attempts.
    – andcoz
    Mar 24, 2017 at 8:11
  • 1
    What happens if you try mount -o rw,hard,intr,rsize=32768,wsize=32768,tcp,noac,nfsvers=3,timeo=600 -t nfs Server:/backup01 /backup01? Note that I used the same options of fstab line but the bg one.
    – andcoz
    Mar 24, 2017 at 8:14
  • Don't you need uid and gid?
    – Thushi
    Mar 24, 2017 at 9:08
  • I did turn on debugging (rpcdebug -m nfsd all ) and found these errors in /var/log/messages Mar 24 12:56:23 iccerpdb11-dr mountd[32043]: Caught signal 15, un-registering and exiting. Mar 24 12:56:23 iccerpdb11-dr kernel: [519350.660146] nfsd: freeing readahead buffers. Mar 24 12:56:23 iccerpdb11-dr kernel: [519350.660328] nfsd: last server has exited, flushing export cache Mar 24 12:56:23 iccerpdb11-dr kernel: [519350.746779] set_max_drc nfsd_drc_max_mem 20639744 Mar 24 12:56:23 iccerpdb11-dr kernel: [519350.758818] nfsd: creating service
    – Bubble
    Mar 27, 2017 at 0:44

1 Answer 1

0

I found the issue was with the TCP switch and found out that the backup server had been rebuilt and they didnt bind the ports, so all nfs connections were defaulting to UDP, as MOUNTD had picked up a blocked port. If you dont bind the ports when the machine is rebooted it will change the port for the below nfs components.

To Bind the Ports;

Uncomment or add these lines to /etc/sysconfig/nfs with the ports you want to use:

  • RQUOTAD_PORT=875
  • LOCKD_TCPPORT=32803
  • LOCKD_UDPPORT=32769
  • MOUNTD_PORT=892
  • STATD_PORT=662

dont forget too restart nfs service.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .