1

While trying to run a module from within yast in Tumbleweed openSUSE, the module crashed and it says in terminal

Run command: /sbin/yast2 sw_single &
terminate called after throwing an instance of 'YUIPluginException'
  what():  Couldn't load plug-in qt
YaST got signal 6 at file /usr/share/YaST2/modules/Wizard.rb:782
  sender PID: 7211
/sbin/yast2: line 440:  7211 中止                  (core dumped) $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

What this could be ?

 zypper search libyui* 

is:

S | 名前                     | 概要                                 | 種類      
--+--------------------------+--------------------------------------+-----------
  | libyui-devel             | Libyui header files                  | パッケージ
i | libyui-doc               | Libyui documentation                 | パッケージ
  | libyui-ncurses-devel     | Libyui-ncurses header files          | パッケージ
i | libyui-ncurses-doc       | Libyui-ncurses documentation         | パッケージ
  | libyui-ncurses-pkg-devel | Libyui-ncurses-pkg header files      | パッケージ
i | libyui-ncurses-pkg-doc   | Libyui-ncurses-pkg documentation     | パッケージ
i | libyui-ncurses-pkg7      | Libyui - yast2 package selector wi-> | パッケージ
i | libyui-ncurses7          | Libyui - Character Based User Inte-> | パッケージ
  | libyui-qt-devel          | Libyui-qt header files               | パッケージ
i | libyui-qt-doc            | Libyui-qt documentation              | パッケージ
  | libyui-qt-graph-devel    | Libyui-qt-graph header files         | パッケージ
i | libyui-qt-graph-doc      | Libyui-qt-graph documentation        | パッケージ
  | libyui-qt-graph7         | Libyui - Qt Graph Widget             | パッケージ
  | libyui-qt-pkg-devel      | Libyui-qt-pkg header files           | パッケージ
i | libyui-qt-pkg-doc        | Libyui-qt-pkg documentation          | パッケージ
i | libyui-qt-pkg7           | Libyui - Qt Package Selector         | パッケージ
i | libyui-qt7               | Libyui - Qt User Interface           | パッケージ
i | libyui7                  | Libyui - GUI-abstraction library     | パッケージ

Update, it seems to be related to a specific package/ パッケージ as cited here but making the process listed I still dont get the UI up. Despite the page speaks about novell linux, and Im open Suse, there is no

xorg-x11-libXrender-7.4-1.23.1

but instead is

libXrender1-0.9.10-1.1.x86_64

So what would be needed? Thanks in advance

  • Comment posted as answer by @PeterWegener : "I had the same problem and an identical error message when starting yast2 from the command line -- and the fix worked for me as well. Thanks!" – peterh Sep 24 '17 at 19:33
1

I had faced with the same problem and paid attention that my system only have libyui-qt7 but not libyui-qt8.

zypper se libyui-qt
Loading repository data...
Reading installed packages...

S  | Name              | Summary                       | Type   
---+-------------------+-------------------------------+--------
i+ | libyui-qt-graph7  | Libyui - Qt Graph Widget      | package
   | libyui-qt-graph8  | Libyui - Qt Graph Widget      | package
i+ | libyui-qt-pkg7    | Libyui - Qt Package Selector  | package
   | libyui-qt-pkg8    | Libyui - Qt Package Selector  | package
i+ | libyui-qt7        | Libyui - Qt User Interface    | package
   | libyui-qt8        | Libyui - Qt User Interface    | package

I have resolved it by installing x86-64 version of the library libyui-qt8 and now any module of the Yast starts successfully.

zypper in libyui-qt8
2

I had a similar problem

 Run command: /sbin/yast2 sw_single &
 terminate called after throwing an instance of 'YUIPluginException'
  what():  Couldn't load plug-in qt
 /sbin/yast2: line 448:  4353 Aborted                 (core dumped) $ybindir/y2start $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

 zypper se libyui

was

 S  | Name                            | Summary                                                     | Type   
 ---+---------------------------------+-------------------------------------------------------------+--------
    | libyui-devel                    | Libyui header files                                         | package
    | libyui-doc                      | Libyui documentation                                        | package
    | libyui-ncurses-devel            | Libyui-ncurses header files                                 | package
    | libyui-ncurses-doc              | Libyui-ncurses documentation                                | package
    | libyui-ncurses-pkg-devel        | Libyui-ncurses-pkg header files                             | package
    | libyui-ncurses-pkg-doc          | Libyui-ncurses-pkg documentation                            | package
 i+ | libyui-ncurses-pkg7             | Libyui - yast2 package selector widget for the ncurses UI   | package
 i  | libyui-ncurses-pkg8             | Libyui - yast2 package selector widget for the ncurses UI   | package
 i+ | libyui-ncurses7                 | Libyui - Character Based User Interface                     | package
 i  | libyui-ncurses8                 | Libyui - Character Based User Interface                     | package
    | libyui-qt-devel                 | Libyui-qt header files                                      | package
    | libyui-qt-doc                   | Libyui-qt documentation                                     | package
    | libyui-qt-graph-devel           | Libyui-qt-graph header files                                | package
    | libyui-qt-graph-doc             | Libyui-qt-graph documentation                               | package
 i+ | libyui-qt-graph7                | Libyui - Qt Graph Widget                                    | package
    | libyui-qt-graph8                | Libyui - Qt Graph Widget                                    | package
    | libyui-qt-pkg-devel             | Libyui-qt-pkg header files                                  | package
    | libyui-qt-pkg-doc               | Libyui-qt-pkg documentation                                 | package
 i+ | libyui-qt-pkg7                  | Libyui - Qt Package Selector                                | package
    | libyui-qt-pkg8                  | Libyui - Qt Package Selector                                | package
 i+ | libyui-qt7                      | Libyui - Qt User Interface                                  | package
    | libyui-qt8                      | Libyui - Qt User Interface                                  | package
 i+ | libyui7                         | Libyui - GUI-abstraction library                            | package
 i  | libyui8                         | Libyui - GUI-abstraction library                            | package
    | ruby2.4-rubygem-libyui-rake     | Rake tasks providing basic work-flow for libyui development | package
    | ruby2.4-rubygem-libyui-rake-doc | RDoc documentation for libyui-rake                          | package

Fixed by

 zypper in libyui-qt8 libyui-qt-graph8 libyui-qt-pkg8
1

I used an explicit command line option:

yast2 -gtk

to avoid the line 440 core dump. This is under openSUSE 42.2 for the yast2 binary of 2017-03-28.

  • yast2 --gtk is not supported anymore. yast or yast2 --ncurses will work. – Anton Oct 1 '17 at 19:57

protected by Community Sep 11 '18 at 18:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.