5

I installed Fedora 25 on my Thinkpad E470 and the Trackpoint works well. But I cannot use the middle button (the button between left and right mouse click) to scroll.

Referring to this source it should be possible.

I found several hints on how to enable this feature on Xorg but I have no clue how to get it work with wayland.

Can anybody help out?

Related button and trackpoint

OS Info:

 Fedora 25
 Gnome 3.22.2
 Wayland 1.12.0
 libinput 1.6.3

Update: Also libinput-debug-events does not recognize pressing the middle mouse button. libinput-list-devices prints the following:

Device:           TPPS/2 IBM TrackPoint
Kernel:           /dev/input/event8
Group:            8
Seat:             seat0, default
Capabilities:     pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   *button
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   flat *adaptive
Rotation:         n/a
5
  • Does it work without Wayland (X11 session?). – Jakuje Mar 24 '17 at 18:15
  • It is not working out of the box on X11. – minils Mar 25 '17 at 10:39
  • I noticed that with xev the middle button is not recognized. – minils Mar 25 '17 at 11:05
  • 1
    If i remember well it worked for me with thinkpad e440s so it is probably sending some different events in the new thinkpad and needs an adjuatment for a driver. – Jakuje Mar 25 '17 at 18:04
  • 1
    nope. Not working on T440s with X11 (partially because I don't have the middle button). But on Dell Latitude E6440 it worked just fine (with Ubuntu 16.10) so there is certainly some difference in drivers. – Jakuje Mar 27 '17 at 14:56
2

As I found out the linux kernel had a bug that prevented Fedora from detecting the trackpoint. As far as I know only trackpoints from the new *70 series are affected.

The bug was fixed in Linux 4.13.

0

xf86-input-libinput - I'm running this one on X11, but can it be X related? If yes, try to install xWayland so you can run X related things on Wayland...

By the way, xev requires manual interaction while libinput (specifically for track-point middle button usage) does not. As I'm lazy, I use libinput.

1
  • There is no such package xf86-input-libinput in the fedora repos.. I mean I have libinput and xorg-x11-drv-libinput installed. But it doesn't help. – minils Jun 20 '17 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.