3

terminology installed (apt update + apt install), and runs fine in a Lubuntu 16.04 fresh installation. But when trying to display a picture (or show thumbnail images with tyls), it always raises this error:

$ tycat titan.png
ERR<1714>:emotion-generic modules/emotion/generic/emotion_generic.c:1838 _players_load() no generic players available



$

followed by a blank space which is the size of the picture to show.

Tried to install the generic players following these instructions:

wget http://download.enlightenment.org/rel/libs/emotion_generic_players/emotion_generic_players-1.17.0.tar.gz
tar -xzf emotion_generic_players-1.17.0.tar.gz
cd emotion_generic_players-1.17.0
./configure --prefix=/usr
make
sudo make install

but did not work:

checking for EMOTION... no
configure: error: Package requirements (emotion >= 1.17) were not met:

No package 'emotion' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.

Alternatively, you may set the environment variables EMOTION_CFLAGS and EMOTION_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Also installed vlc, just in case it might need it, but nothing changed.

Update: Compilation worked for version 1.8.2 (emotion_generic_players-1.8.2):

------------------------------------------------------------------------
emotion_generic_players 1.8.2
------------------------------------------------------------------------

Configuration Options Summary:
  Build Profile..........: dev

Players:
  VLC....................: yes

Compilation..............: make (or gmake)
  CPPFLAGS...............: 
  CFLAGS.................: -g -O2
  CXXFLAGS...............: 
  LDFLAGS................: 

Installation.............: make install (as root if needed, with 'su' or 'sudo')
  prefix.................: /usr
  emotion generic players: /usr/lib/x86_64-linux-gnu/emotion/generic_players/linux-gnu-x86_64-1.8.6

but the problem remains after make and make install: ERR<4002>:emotion-generic modules/emotion/generic/emotion_generic.c:1838 _players_load() no generic players available

10
  • Apparently, emotion-generic-players are not present in Debian repositories so you indeed have to compile them by hand. What the error message tells you is that you're lacking the emotion library, which is present in the repositories. Could you install libemotion-dev and retry?
    – lgeorget
    Mar 24, 2017 at 8:44
  • @lgeorget It's weird, cause the library is already installed: libemotion-dev is already the newest version (1.8.6-2.5)., and it keeps reporting an error: Requested 'emotion >= 1.17' but version of emotion is 1.8.6.
    – nightcod3r
    Mar 24, 2017 at 12:38
  • Ok so the library available in the repository is too old. Library emotion 1.18 is still experimental (packages.debian.org/experimental/libemotion-dev). I think your best option would be to look for an older release of emotion-generic-players, compatible with emotion 1.8 (maybe emotion-generic-players-1.8 if they release their apps along with the library).
    – lgeorget
    Mar 24, 2017 at 12:47
  • @lgeorget I've tried 1.13, but same result: configure: error: Package requirements (emotion >= 1.13) were not met: Requested 'emotion >= 1.13' but version of emotion is 1.8.6.
    – nightcod3r
    Mar 24, 2017 at 12:49
  • Yup, that's the same problem, because 1.13 is also too recent for library 1.8.6. Try release 1.8.
    – lgeorget
    Mar 24, 2017 at 12:51

1 Answer 1

5

Things can get really hard if not installed in the proper way. This is how it worked for me:

Firstly, remove all previous stuff

sudo apt-get remove enlightenment terminology
sudo apt autoremove

Then, follow these instructions

sudo add-apt-repository ppa:niko2040/e19
sudo apt-get update
sudo apt-get install enlightenment terminology

This adds a repository curated by a maintainer involved in Enlightenment and installs packages enlightenment and terminology from this repository instead of the older (currently) non-working packages available in the official Ubuntu repositories.

Logout and login again, no need to select the Enlightenment desktop environment (as the webpage suggests). Now, thumbnails, pictures and video show up in Terminology.

credits: webpage.

(Thanks to @lgeorget for all his help in getting to the solution.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .