-1

I have created a fish function named proot but there is an Ubuntu package with the same name.

When I type 'proot' into my fish shell, I get

 ~> proot
The program 'proot' is currently not installed. You can install it by     typing:
sudo apt-get install proot

Running functions -n does show me my proot function, I just can't run it.

I have tried to run the equivalent of bash's UNSET command_not_found_handle (set -e command_not_found_handle in my config.fish), which should theoretically disable apt's prompting to install, but it doesn't seem to matter.

Is there a way to make a function name that conflicts with a package, or disable apt's prompting from within fish? (I have renamed to groot and confirmed that it works just fine.)

2

sigh never mind. I can confirm that this does indeed work. A copy/paste error in my Puppet manifest meant I was copying two similarly named aliases from the same source file. So even though I had proot.fish it was defining a function named sroot.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.