-1

So I am using an Elitebook 8540p running Fedora 25 and have been trying to enable middle mouse scrolling so that I can use the pointing stick for scrolling. The device is listed as "PS/2 Generic Mouse" by xinput and I have tried messing with the properties of that device but nothing I do will allow me to scroll. Here are the current settings:

Device 'PS/2 Generic Mouse':
Device Enabled (139):   1
Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
Device Accel Profile (265): 0
Device Accel Constant Deceleration (266):   1.000000
Device Accel Adaptive Deceleration (267):   1.000000
Device Accel Velocity Scaling (268):    10.000000
Device Product ID (263):    2, 1
Device Node (262):  "/dev/input/event4"
Evdev Axis Inversion (269): 0, 0
Evdev Axes Swap (271):  0
Axis Labels (272):  "Rel X" (149), "Rel Y" (150)
Button Labels (273):    "Button Left" (142), "Button Middle" (143), "Button Right" (144), "Button Wheel Up" (145), "Button Wheel Down" (146), "Button Horiz Wheel Left" (147), "Button Horiz Wheel Right" (148)
Evdev Scrolling Distance (274): 0, 0, 0
Evdev Middle Button Emulation (275):    0
Evdev Middle Button Timeout (276):  50
Evdev Middle Button Button (277):   2
Evdev Third Button Emulation (278): 0
Evdev Third Button Emulation Timeout (279): 1000
Evdev Third Button Emulation Button (280):  3
Evdev Third Button Emulation Threshold (281):   20
Evdev Wheel Emulation (282):    1
Evdev Wheel Emulation Axes (283):   6, 7, 4, 5
Evdev Wheel Emulation Inertia (284):    10
Evdev Wheel Emulation Timeout (285):    200
Evdev Wheel Emulation Button (286): 2
Evdev Drag Lock Buttons (287):  0
  • First step is to run evtest /dev/input/event4 (or whatever is the current device, the numbers need to stay constant) as root and check what kind of events you receive for "middle mouse scrolling", if you receive any events at all. – dirkt Mar 23 '17 at 7:59
  • @dirkt Running I tried just moving the mouse up and down with the pointing stick and then holding the middle button and and moving the mouse up and down (which should activate middle mouse scrolling) and both show the same output. – Alex Waibel Mar 24 '17 at 18:42
  • That means the PS/2 kernel driver doesn't understand whatever events your Laptop is generating, and doesn't put them into /dev/input/event. So you need a different kernel driver, but the question is "which driver?". If you are adventerous, you can enable serio_raw on the PS/2 mouse port (aux) and hexdump the protocol, but even knowing the protocol, we still need to find a matching driver. – dirkt Mar 25 '17 at 8:30
0

It appears that this feature is simply not supported for this device on this version of Fedora. I was able to get this feature working on an old IBM USB keyboard that had a trackpoint so I will just be using that instead of the keyboard built into the laptop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.