1

I am trying to install Open MPI 2.1.0 version on our CentOS machine. I followed these steps:

tar -xvf openmpi-*
cd openmpi-*
./configure --prefix="/home/$USER/.openmpi"

*** C compiler and preprocessor
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) unsupported
checking whether gcc understands -c and -o together... (cached) yes
checking for gcc option to accept ISO C99... unsupported
configure: WARNING: Open MPI requires a C99 compiler
configure: error: Aborting.

I searched for same problems like this and tried to install C99 and whatever missing. and no progress. Do you have comment or solution?

  • What version of gcc is installed? – Kusalananda Mar 22 '17 at 8:31
  • gcc (GCC) 4.8.2 20140120 (Red Hat 4.8.2-15) – Abolfazl Mar 22 '17 at 8:33
  • Well, that's definitely a C99 compiler (and C89). Could you add the part from config.log where it fails to compile the last test? (or put the whole config.log on pastebin.com or somesuch place and link to it?) – Kusalananda Mar 22 '17 at 8:47
  • I provided it in my dropbox – Abolfazl Mar 22 '17 at 8:55
  • It looks like gcc is acting like a C++ compiler... I don't know why. You didn't link gcc to g++ or something similar? – Kusalananda Mar 22 '17 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.