4

On manjaro 17 with virtualbox 5.1.6 or 5.1.8 as soon as I install the guest additional driver to my Windows 7 VM i3 start resizing automatically the VM windows to its minimum making it unusable.

  • It does not happen if I load a linux VM.
  • It does not happen if I load the windows VM using gnome from Ubuntu.

The bug happens once you are on the desktop and might be related to the use of graphic driver/virtual graphic card not used similarly in the preceding steps.

EDIT
Did not reproduce on an other computer with different configuration, it is probably hardware related

  • So you think it's because if i3? Tried with other window managers? – schaiba Mar 21 '17 at 7:26
  • Well, there are two possible 'hacky' workaround I see. First one is to use VM on a separate screen (desktop) and forcing it to go fullscreen (std. shortcut is mod+shift+f). The second one is to make it a floating window - std. shortcut is mod+shift+space). Wonder if this would help - please let me know. – ddnomad Mar 21 '17 at 8:12
  • As I am just starting with i3 and hadn't time yet to go through a proper tutorial, I would be ashamed if the second solution work! Thanks a lot I'l try that tonight when I am back home. – zakrapovic Mar 21 '17 at 8:27
  • It did not work. The windows was actually already floating, but forcing to have it fit to i3 tilling made things worst. Full screen is unusable as well. I found a workaround. – zakrapovic Mar 21 '17 at 17:17
  • at the moment (or, since 2016) there is a bug with resizing in 5.1.6 virtualbox.org/ticket/15863?cversion=0&cnum_hist=2 ... but the answers below point to the right direction (remember to install appropriate guest additions for your version) – eli Sep 26 '17 at 6:51
5

In vritualbox menu bar, go to View > Vritual screen > pick a resolution.
The screen stop to be automatically resized permanently

1

Found this topic by googling the same issue. The solution is very simple: There is an option for virtualbox named Autoresize guest display. Turning it off cause work vbox with i3 just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.