1

I recently bought a OrangePi Zero Single Board Computer. It works fine but i am facing an issue now, when i boot the Pi without Ethernet, router assigns the IP to the WiFi of the PI but i tried to ping it. It says connection time out and when i try to ssh in it, it doesn't connect.

But if i boot my pi with Ethernet connected, both interfaces eth0 and wlan0 works fine and i can even ssh using both wlan0 and eth0.

I even tried to disconnect the Ethernet in between and then tried to ping wlan0 interface, again the same problem persists. If i even connect the Ethernet again both interface works fine.

I am using nmtui network manager. Therefore, my /etc/network/interfaces file is empty

root@orangepizero:~# nano /etc/network/interfaces
# This file intentionally left blank
#
# All interfaces are handled by network-manager, use nmtui or nmcli on
# server/headless images or the "Network Manager" GUI on desktop images

Here is my ip routing table when eth0 and wlan0 is connected

root@orangepizero:~# ip route
default via 192.168.1.1 dev eth0  proto static  metric 1024
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.120
192.168.1.0/24 dev wlan0  proto kernel  scope link  src 192.168.1.130

Here is my sshd_config file... Note : I am listening on all IP Addresses.

root@orangepizero:/etc/ssh# nano sshd_config
# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
HostKey /etc/ssh/ssh_host_ed25519_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 1024

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for 
RhostsRSAAuthentication

Here is the dmesg log ...

root@orangepizero:/home/mayank# dmesg


[    0.938512] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.958710] sunxi-ehci sunxi-ehci.1: SW USB2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.958785] sunxi-ehci sunxi-ehci.1: new USB bus registered, assigned bus number 1
[    0.959878] sunxi-ehci sunxi-ehci.1: irq 104, io mem 0xf1c1a000
[    0.970075] sunxi-ehci sunxi-ehci.1: USB 0.0 started, EHCI 1.00
[    0.971318] hub 1-0:1.0: USB hub found
[    0.971364] hub 1-0:1.0: 1 port detected
[    0.992132] sunxi-ehci sunxi-ehci.2: SW USB2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.992193] sunxi-ehci sunxi-ehci.2: new USB bus registered, assigned bus number 2
[    0.993010] sunxi-ehci sunxi-ehci.2: irq 106, io mem 0xf1c1b000
[    1.010068] sunxi-ehci sunxi-ehci.2: USB 0.0 started, EHCI 1.00
[    1.011223] hub 2-0:1.0: USB hub found
[    1.011278] hub 2-0:1.0: 1 port detected
[    1.032097] sunxi-ehci sunxi-ehci.3: SW USB2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.032157] sunxi-ehci sunxi-ehci.3: new USB bus registered, assigned bus number 3
[    1.032993] sunxi-ehci sunxi-ehci.3: irq 108, io mem 0xf1c1c000
[    1.050070] sunxi-ehci sunxi-ehci.3: USB 0.0 started, EHCI 1.00
[    1.051154] hub 3-0:1.0: USB hub found
[    1.051205] hub 3-0:1.0: 1 port detected
[    1.071966] sunxi-ehci sunxi-ehci.4: SW USB2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.072026] sunxi-ehci sunxi-ehci.4: new USB bus registered, assigned bus number 4
[    1.072806] sunxi-ehci sunxi-ehci.4: irq 110, io mem 0xf1c1d000
[    1.090061] sunxi-ehci sunxi-ehci.4: USB 0.0 started, EHCI 1.00
[    1.091178] hub 4-0:1.0: USB hub found
[    1.091226] hub 4-0:1.0: 1 port detected
[    1.092013] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    1.112150] sunxi-ohci sunxi-ohci.1: SW USB2.0 'Open' Host Controller (OHCI) Driver
[    1.112210] sunxi-ohci sunxi-ohci.1: new USB bus registered, assigned bus number 5
[    1.112278] sunxi-ohci sunxi-ohci.1: irq 105, io mem 0xf1c1a400
[    1.175168] hub 5-0:1.0: USB hub found
[    1.175210] hub 5-0:1.0: 1 port detected
[    1.195989] sunxi-ohci sunxi-ohci.2: SW USB2.0 'Open' Host Controller (OHCI) Driver
[    1.196051] sunxi-ohci sunxi-ohci.2: new USB bus registered, assigned bus number 6
[    1.196115] sunxi-ohci sunxi-ohci.2: irq 107, io mem 0xf1c1b400
[    1.255230] hub 6-0:1.0: USB hub found
[    1.255276] hub 6-0:1.0: 1 port detected
[    1.276126] sunxi-ohci sunxi-ohci.3: SW USB2.0 'Open' Host Controller (OHCI) Driver
[    1.276185] sunxi-ohci sunxi-ohci.3: new USB bus registered, assigned bus number 7
[    1.276249] sunxi-ohci sunxi-ohci.3: irq 109, io mem 0xf1c1c400
[    1.335058] hub 7-0:1.0: USB hub found
[    1.335097] hub 7-0:1.0: 1 port detected
[    1.355806] sunxi-ohci sunxi-ohci.4: SW USB2.0 'Open' Host Controller (OHCI) Driver
[    1.355865] sunxi-ohci sunxi-ohci.4: new USB bus registered, assigned bus number 8
[    1.355928] sunxi-ohci sunxi-ohci.4: irq 111, io mem 0xf1c1d400
[    1.415077] hub 8-0:1.0: USB hub found
[    1.415116] hub 8-0:1.0: 1 port detected
[    1.415828] Initializing USB Mass Storage driver...
[    1.416301] usbcore: registered new interface driver usb-storage
[    1.416324] USB Mass Storage support registered.
[    1.416445] usbcore: registered new interface driver ums-alauda
[    1.416567] usbcore: registered new interface driver ums-cypress
[    1.416690] usbcore: registered new interface driver ums-datafab
[    1.416788] usbcore: registered new interface driver ums_eneub6250
[    1.416886] usbcore: registered new interface driver ums-freecom
[    1.416991] usbcore: registered new interface driver ums-isd200
[    1.417090] usbcore: registered new interface driver ums-jumpshot
[    1.417192] usbcore: registered new interface driver ums-karma
[    1.417290] usbcore: registered new interface driver ums-onetouch
[    1.417420] usbcore: registered new interface driver ums-realtek
[    1.417525] usbcore: registered new interface driver ums-sddr09
[    1.417632] usbcore: registered new interface driver ums-sddr55
[    1.417740] usbcore: registered new interface driver ums-usbat
[    1.418184]  uinput result 0 , vmouse_init
[    1.419446] mousedev: PS/2 mouse device common for all mice
[    1.419915] sunxikbd_init failed.
[    1.419938] sunxikbd_init failed.
[    1.419961] ls_fetch_sysconfig_para: ls_unused.
[    1.419978] ltr_init: ls_fetch_sysconfig_para err.
[    1.420679] [RTC] WARNING: Rtc time will be wrong!!
[    1.420699] [RTC] WARNING: use *internal OSC* as clock source
[    1.421225] sunxi-rtc sunxi-rtc: rtc core: registered sunxi-rtc as rtc0
[    1.421333] i2c /dev entries driver
[    1.422157] sunxi cedar version 0.1
[    1.422246] [cedar]: install start!!!
[    1.422622] [cedar]: install end!!!
[    1.422990] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x20, dev addr: 0x18)
[    1.423206] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x20, dev addr: 0x19)
[    1.423410] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x20, dev addr: 0x1a)
[    1.423613] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x20, dev addr: 0x29)
[    1.423815] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x20, dev addr: 0x2a)
[    1.424020] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x20, dev addr: 0x2b)
[    1.424222] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x20, dev addr: 0x4c)
[    1.424450] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x20, dev addr: 0x4d)
[    1.424670] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x20, dev addr: 0x4e)
[    1.424917] sunxi_i2c_do_xfer()985 - [i2c1] incomplete xfer (status: 0x20, dev addr: 0x18)
[    1.425155] sunxi_i2c_do_xfer()985 - [i2c1] incomplete xfer (status: 0x20, dev addr: 0x19)
[    1.425393] sunxi_i2c_do_xfer()985 - [i2c1] incomplete xfer (status: 0x20, dev addr: 0x1a)
[    1.425630] sunxi_i2c_do_xfer()985 - [i2c1] incomplete xfer (status: 0x20, dev addr: 0x29)
[    1.425868] sunxi_i2c_do_xfer()985 - [i2c1] incomplete xfer (status: 0x20, dev addr: 0x2a)
[    1.426107] sunxi_i2c_do_xfer()985 - [i2c1] incomplete xfer (status: 0x20, dev addr: 0x2b)
[    1.426344] sunxi_i2c_do_xfer()985 - [i2c1] incomplete xfer (status: 0x20, dev addr: 0x4c)
[    1.426581] sunxi_i2c_do_xfer()985 - [i2c1] incomplete xfer (status: 0x20, dev addr: 0x4d)
[    1.426818] sunxi_i2c_do_xfer()985 - [i2c1] incomplete xfer (status: 0x20, dev addr: 0x4e)
[    1.426849] sunxi_wdt_init_module: sunxi WatchDog Timer Driver v1.0
[    1.427189] sunxi_wdt_probe: devm_ioremap return wdt_reg 0xf1c20ca0, res->start 0x01c20ca0, res->end 0x01c20cbf
[    1.427511] sunxi_wdt_probe: initialized (g_timeout=16s, g_nowayout=0)
[    1.427538] wdt_enable, write reg 0xf1c20cb8 val 0x00000000
[    1.427560] timeout_to_interv, line 167
[    1.427577] interv_to_timeout, line 189
[    1.427597] wdt_set_tmout, write 0x000000b0 to mode reg 0xf1c20cb8, actual timeout 16 sec
[    1.428429] device-mapper: ioctl: 4.22.0-ioctl (2011-10-19) initialised: dm-devel@redhat.com
[    1.428829] calibrat: max_cpufreq 1008Mhz Type 1!
[    1.428855] [cpu_freq] ERR:get cpu extremity frequency from sysconfig failed, use max_freq
[    1.429484] [mmc]: SD/MMC/SDIO Host Controller Driver(v1.111 2015-4-13 15:24) Compiled in Feb 23 2017 at 19:53:48
[    1.429553] [mmc]: get mmc0's sdc_power is null!
[    1.429612] [mmc]: get mmc1's sdc_power is null!
[    1.429631] [mmc]: get mmc1's 2xmode ok, val = 1
[    1.429651] [mmc]: get mmc1's ddrmode ok, val = 1
[    1.429684] [mmc]: MMC host used card: 0x3, boot card: 0x0, io_card 2
[    1.434389] [mmc]: sdc0 power_supply is null
[    1.437189] no blue_led, ignore it!
[    1.437669] Registered led device: red_led
[    1.437903] Registered led device: green_led
[    1.437936] no led_0, ignore it!
[    1.437952] no led_1, ignore it!
[    1.437967] no led_2, ignore it!
[    1.437982] no led_3, ignore it!
[    1.437997] no led_4, ignore it!
[    1.438012] no led_5, ignore it!
[    1.438026] no led_6, ignore it!
[    1.438041] no led_7, ignore it!
[    1.439742] usbcore: registered new interface driver usbhid
[    1.439767] usbhid: USB HID core driver
[    1.448220] asoc: sndcodec <-> sunxi-codec mapping ok
[    1.450721] [DAUDIO]sunxi-daudio cannot find any using configuration for controllers, return directly!
[    1.451109] [I2S]snddaudio cannot find any using configuration for controllers, return directly!
[    1.451138] [DAUDIO0] driver not init,just return.
[    1.458288] asoc: sndhdmi <-> sunxi-hdmiaudio.0 mapping ok
[    1.461109] oprofile: using arm/armv7-ca7
[    1.461461] u32 classifier
[    1.461481]     Performance counters on
[    1.461497]     input device check on
[    1.461512]     Actions configured
[    1.461896] IPv4 over IPv4 tunneling driver
[    1.463190] TCP: bic registered
[    1.463213] TCP: cubic registered
[    1.463230] TCP: westwood registered
[    1.463246] TCP: highspeed registered
[    1.463262] TCP: hybla registered
[    1.463277] TCP: htcp registered
[    1.463293] TCP: vegas registered
[    1.463309] TCP: veno registered
[    1.463324] TCP: scalable registered
[    1.463340] TCP: lp registered
[    1.463356] TCP: yeah registered
[    1.463372] TCP: illinois registered
[    1.463387] Initializing XFRM netlink socket
[    1.463837] NET: Registered protocol family 10
[    1.466221] NET: Registered protocol family 17
[    1.466284] NET: Registered protocol family 15
[    1.466374] Registering the dns_resolver key type
[    1.467531] VFP support v0.3: implementor 41 architecture 2 part 30 variant 7 rev 5
[    1.467576] ThumbEE CPU extension supported.
[    1.467619] Registering SWP/SWPB emulation handler
[    1.468734] registered taskstats version 1
[    1.470417] cmdline,disp=
[    1.470791] [DISP] disp_init_tv,line:539:screen 0 do not support TV TYPE!
[    1.470830] [DISP] bsp_disp_tv_register,line:990:'ptv is null
[    1.470853] tv registered!!
[    1.470980] [DISP] disp_device_attached_and_enable,line:159:attched ok, mgr1<-->device1, type=2, mode=11
[    1.480565] ths_fetch_sysconfig_para: type err  device_used = 1.
[    1.483260] CPU Budget:corekeeper enabled
[    1.483749] CPU Budget:Register notifier
[    1.483775] CPU Budget:register Success
[    1.483800] sunxi-budget-cooling sunxi-budget-cooling: Cooling device registered: thermal-budget-0
[    1.490595] [rf_pm]: Did not config module_power1 in sys_config
[    1.490623] [rf_pm]: Did not config module_power2 in sys_config
[    1.490645] [rf_pm]: Did not config module_power3 in sys_config
[    1.490666] [rf_pm]: mod has no chip_en gpio
[    1.490684] [rf_pm]: regulator on.
[    1.490717] [rf_pm]: set losc_out 32k out[wifi_pm]: set wl_reg_on 1 !
[    1.549430] mmc0: new high speed SDHC card at address aaaa
[    1.550522] mmcblk0: mmc0:aaaa SS08G 7.40 GiB
[    1.553946]  mmcblk0: p1
[    1.554969] mmcblk mmc0:aaaa: Card claimed for testing.
[    1.554999] mmc0:aaaa: SS08G 7.40 GiB
[    1.591339] [wifi_pm]: get wifi_sdc_id failed
[    1.592912] [mmc]: sdc1 power_supply is null
[    1.648738] mmc1: new high speed SDIO card at address 0001
[    1.691419] [wifi_pm]: wifi gpio init is OK !!
[    1.691532] [rfkill]: init no bt used in configuration
[    1.691555] ALSA device list:
[    1.691571]   #0: audiocodec
[    1.691587]   #1: sndhdmi
[    1.693346] Freeing init memory: 332K
[    1.776600] systemd-udevd[96]: starting version 215
[    2.613445] Btrfs loaded
[    3.084545] EXT4-fs (mmcblk0p1): mounted filesystem with writeback data mode. Opts: (null)
[    4.290630] systemd[1]: systemd 215 running in system mode. (+PAM +AUDIT +SELINUX +IMA +SYSVINIT +LIBCRYPTSETUP +GCRYPT +ACL +XZ -SECCOMP -APPARMOR)
[    4.291299] systemd[1]: Detected architecture 'arm'.
[    4.335894] systemd[1]: Set hostname to <orangepizero>.
[    4.766400] systemd[1]: Cannot add dependency job for unit display-manager.service, ignoring: Unit display-manager.service failed to load: No such file or directory.
[    4.771956] systemd[1]: Expecting device dev-ttyGS0.device...
[    4.790320] systemd[1]: Expecting device dev-ttyS0.device...
[    4.810269] systemd[1]: Starting Forward Password Requests to Wall Directory Watch.
[    4.810757] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[    4.810903] systemd[1]: Starting Remote File Systems (Pre).
[    4.830253] systemd[1]: Reached target Remote File Systems (Pre).
[    4.830450] systemd[1]: Starting Encrypted Volumes.
[    4.850252] systemd[1]: Reached target Encrypted Volumes.
[    4.850439] systemd[1]: Starting Dispatch Password Requests to Console Directory Watch.
[    4.850864] systemd[1]: Started Dispatch Password Requests to Console Directory Watch.
[    4.850987] systemd[1]: Starting Paths.
[    4.870256] systemd[1]: Reached target Paths.
[    4.870515] systemd[1]: Starting Arbitrary Executable File Formats File System Automount Point.
[    4.890269] systemd[1]: Set up automount Arbitrary Executable File Formats File System Automount Point.
[    4.890460] systemd[1]: Starting Root Slice.
[    4.910246] systemd[1]: Created slice Root Slice.
[    4.910384] systemd[1]: Starting /dev/initctl Compatibility Named Pipe.
[    4.930263] systemd[1]: Listening on /dev/initctl Compatibility Named Pipe.
[    4.930400] systemd[1]: Starting Delayed Shutdown Socket.
[    4.950245] systemd[1]: Listening on Delayed Shutdown Socket.
[    4.950379] systemd[1]: Starting Journal Socket (/dev/log).
[    4.970251] systemd[1]: Listening on Journal Socket (/dev/log).
[    4.970392] systemd[1]: Starting User and Session Slice.
[    4.990253] systemd[1]: Created slice User and Session Slice.
[    4.990426] systemd[1]: Starting udev Control Socket.
[    5.010256] systemd[1]: Listening on udev Control Socket.
[    5.010419] systemd[1]: Starting udev Kernel Socket.
[    5.030245] systemd[1]: Listening on udev Kernel Socket.
[    5.030417] systemd[1]: Starting Journal Socket.
[    5.050253] systemd[1]: Listening on Journal Socket.
[    5.050505] systemd[1]: Starting System Slice.
[    5.070262] systemd[1]: Created slice System Slice.
[    5.070580] systemd[1]: Starting Increase datagram queue length...
[    5.211363] systemd[1]: Starting Restore / save the current clock...
[    5.311898] systemd[1]: Starting Create list of required static device nodes for the current kernel...
[    5.411594] systemd[1]: Mounting POSIX Message Queue File System...
[    5.500987] systemd[1]: Starting udev Coldplug all Devices...
[    5.592076] systemd[1]: Mounting Debug File System...
[    5.701113] systemd[1]: Mounted Huge Pages File System.
[    5.707746] systemd[1]: Started Set Up Additional Binary Formats.
[    5.707959] systemd[1]: Starting LSB: Set keymap...
[    5.841077] systemd[1]: Starting system-serial\x2dgetty.slice.
[    5.860404] systemd[1]: Created slice system-serial\x2dgetty.slice.
[    5.860649] systemd[1]: Starting system-getty.slice.
[    5.880314] systemd[1]: Created slice system-getty.slice.
[    5.887902] systemd[1]: Starting Load Kernel Modules...
[    5.981417] systemd[1]: Started File System Check on Root Device.
[    5.981693] systemd[1]: Starting Slices.
[    6.000630] systemd[1]: Reached target Slices.
[    6.020368] systemd[1]: Mounted Debug File System.
[    6.040517] systemd[1]: Mounted POSIX Message Queue File System.
[    6.101352] [XRADIO] Driver Label:L34M.01.08.0002  Feb 23 2017 19:54:01
    [    6.101470] [XRADIO] Allocated hw_priv @ d6e67240
    [    6.102300] [SBUS] XRadio Device:sdio clk=50000000
    [    6.102625] xradio wlan power on
    [    6.102656] gpio wl_reg_on set val 1, act val 1
    [    6.130373] systemd[1]: Started Increase datagram queue length.
    [    6.152709] gpio wl_reg_on set val 0, act val 0
    [    6.154738] gpio wl_reg_on set val 1, act val 1
    [    6.210296] systemd[1]: Started Restore / save the current clock.
    [    6.254812] [XRADIO] Detect SDIO card 1
    [    6.310257] systemd[1]: Started Create list of required static device nodes for the current kernel.
    [    6.470510] systemd[1]: Started LSB: Set keymap.
    [    6.590308] systemd[1]: Started udev Coldplug all Devices.
    [    6.596253] systemd[1]: Time has been changed
    [    6.597349] systemd[1]: Starting Create Static Device Nodes in /dev...
    [    6.601474] [XRADIO_ERR] xradio_load_firmware: can't read config register, err=-110.
    [    6.601501] [XRADIO_ERR] xradio_load_firmware failed(-110).
    [    6.731413] systemd[1]: Starting Syslog Socket.
    [    6.750529] systemd[1]: Listening on Syslog Socket.
    [    6.750859] systemd[1]: Starting Journal Service...
    [    6.890437] systemd[1]: Started Journal Service.
    [    6.938024] xradio wlan power off
    [    6.938078] gpio wl_reg_on set val 0, act val 0
    [    6.988261] [XRADIO] Remove SDIO card 1
    [    6.988579] mmc1: card 0001 removed
    [    6.989029] [mmc]: sdc1 power_supply is null
    [    7.063734] ep_matches, wrn: endpoint already claimed, ep(0xc097afbc, 0xd6a30cc0, ep1in-bulk)
    [    7.063778] ep_matches, wrn: endpoint already claimed, ep(0xc097afbc, 0xd6a30cc0, ep1in-bulk)
    [    7.063807] ep_matches, wrn: endpoint already claimed, ep(0xc097b008, 0xd6a30cc0, ep1out-bulk)
    [    7.063830] gadget_is_softwinner_otg is not -int
    [    7.063846] gadget_is_softwinner_otg is not -int
    [    7.063880] g_serial gadget: Gadget Serial v2.4
    [    7.063913] g_serial gadget: g_serial ready
    [    7.074002] [XRADIO_ERR] xradio_host_dbg_init failed=2599
    [    7.074032] [XRADIO] Driver Label:L34M.01.08.0002  Feb 23 2017 19:54:01
    [    7.074150] [XRADIO] Allocated hw_priv @ d6e5d240
    [    7.074761] xradio wlan power on
    [    7.074798] gpio wl_reg_on set val 1, act val 1
    [    7.124840] gpio wl_reg_on set val 0, act val 0
    [    7.126865] gpio wl_reg_on set val 1, act val 1
    [    7.166700] systemd-udevd[172]: starting version 215
    [    7.226966] [XRADIO] Detect SDIO card 1
    [    7.228536] [mmc]: sdc1 power_supply is null
    [    7.279737] mmc1: new high speed SDIO card at address 0001
    [    7.280968] [SBUS] XRadio Device:sdio clk=50000000
    [    7.282400] [XRADIO] XRADIO_HW_REV 1.0 detected.
    [    7.449751] [XRADIO] Bootloader complete
    [    7.648793] [XRADIO] Firmware completed.
    [    7.652052] [WSM] Firmware Label:XR_C01.08.0043 Jun  6 2016 20:41:04
    [    7.667293] [XRADIO] Firmware Startup Done.
    [    7.669691] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
    [    7.747359] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x20, dev addr: 0x77)
    [    7.747431] bmp085: probe of 0-0077 failed with error -70
    [    7.760504] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x20, dev addr: 0x48)
    [    7.760844] sunxi_i2c_do_xfer()985 - [i2c0] incomplete xfer (status: 0x48, dev addr: 0x48)
    [    8.399751] EXT4-fs (mmcblk0p1): re-mounted. Opts: commit=600,errors=remount-ro
    [    8.775241] Adding 131068k swap on /var/swap.  Priority:-1 extents:1 across:131068k SS
    [   10.538125] systemd-journald[171]: Received request to flush runtime journal from PID 1
    [   12.991199] Registered IR keymap rc-empty
    [   12.992787] rc0: sunxi-ir as /devices/virtual/rc/rc0
    [   13.031684] IR RC5(x) protocol handler initialized
    [   13.158761] rc s_cir0: lirc_dev: driver ir-lirc-codec (sunxi-ir) registered at minor = 0
    [   13.269608] gmac0: probed
    [   13.270238] gmac0 gmac0: eth0: eth0: PHY ID 00441400 at 0 IRQ poll (gmac0-0:00)
    [   15.060372] [STA] !!!xradio_vif_setup: id=0, type=2, p2p=0
    [   15.102065] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   15.270361] PHY: gmac0-0:00 - Link is Up - 100/Full
    [   16.581088] wlan0: authenticate with 60:e3:27:fe:c3:60
    [   16.581151] [STA_WRN] Freq 2437 (wsm ch: 6).
    [   16.620255] wlan0: send auth to 60:e3:27:fe:c3:60 (try 1/3)
    [   16.710994] wlan0: authenticated
    [   16.720147] wlan0: associate with 60:e3:27:fe:c3:60 (try 1/3)
    [   16.724399] wlan0: RX AssocResp from 60:e3:27:fe:c3:60 (capab=0x431 status=0 aid=1)
    [   16.725922] [AP_WRN] [STA] ASSOC HTCAP 11N 58
    [   16.727653] wlan0: associated
    [   16.727929] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

Update : i removed some initial part of dmesg log due to word limit in stack exchange

1

Check your routing table when only wifi is connected. (If I got it correctly, the above is with both, wired and wifi being connected). Does it route correctly then?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.