0

A problem has developed on one of my systems in which terminal output is getting truncated. When I login via SSH for instance and I run For ls -l command only 3 or 4 lines are shown, then the screen hangs. When I connect to the terminal directly, ie via VNC the same happens.

However when I connect via wetty for instance everything is fine.

Any ideas of what the cause could be, or how to diagnose what is happening?

3
  • 1
    If you attempt to replicate this by using netcat, does it persist? Do you have logs? Have you tried looking at a packet capture to see what is going on?
    – DopeGhoti
    Mar 20, 2017 at 17:57
  • @DopeGhoti: Can you use netcat to log in to a server that doesn't support telnet (but only ssh)? Mar 24, 2017 at 4:23
  • Yes. ssh into the remote host, run nc -l 23456, then on your local host, run ls -l / | nc host.example.com 23456. You should see the output of ls on the remote host's terminal.
    – DopeGhoti
    Mar 24, 2017 at 16:17

1 Answer 1

2

I have had this happen when the MTU of some link in the path was misconfigured. Check the configured packet sizes at both ends and as many of the intermediate hops that you have access to. On Linux systems, the ifconfig program will display the info you need.

2
  • This may be the most likely reason. When I connect from another location the problem isn't present. I will try from the original location which was a wireless hotspot to see if the problem only occurs there.
    – vfclists
    Mar 26, 2017 at 7:07
  • On the other hand, the same problem should have occurred when I connected with via the console, so that also needs investigation.
    – vfclists
    Mar 26, 2017 at 7:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.