I am trying to install libgmp sources as I am trying to build some other source that requires gmp.h.

In Cygwin setup-x86_64.exe I Search for gmp and it finds the libgmp line which says "6.1.2-1 Keep" on the left, "n/a" under "Bin?" , and empty checkbox under "Src?".

I check the checkbox and proceed and it appears to install something and succeed. However, gmp.h doesn't appear anywhere under /usr/include (or anywhere else that I can find); and when I run setup-x86_64.exe again, the Src box is unchecked.

What's going wrong? I have tried with a few other libraries too, in all cases the source doesn't seem to appear and the Src checkbox resets next time the setup is run.

  • Are you sure you need the source package? Could be that you need 'the development package libgmp-devel instead. – pak Mar 20 '17 at 2:07
  • @pak you're right, that was what I needed – M.M Mar 20 '17 at 2:26

The development packages include the header files needed when building other software, rather than the source packages. In this case, the libgmp-devel package is what's required.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.