3

I'm unable to connect to the internet after I resume from suspend to ram.
The problem appeared after I fixed resuming from suspend to disk following this answer.

I'm using netctl where the error is pretty much the same as if manually running dhcpcd:

$ sudo dhcpcd enp12s0
DUID ***numbers & letters & colons ***
enp12s0: IAID e3:ed:11:40
enp12s0: soliciting an IPv6 router
enp12s0: soliciting a DHCP lease
enp12s0: no IPv6 Routers available
timed out
dhcpcd exited

The arch wiki suggests extending the timeout; I tried with 40 seconds but no luck. And I don't think the problem lies there since I used to connect for no more than 5-10 seconds.

Forcing --ipv4only does not work, either.

I tried stopping the netctl service before suspending, that didn't work, too.
Edit: Now if I stop the netctl service before suspend I do have working internet after resume and netctl start myservice; I'll be using this routine from now on but I'm still curious how it worked before without having to do netctl stop/start.

Anything else I can do?

  • Are there any firmware or BIOS updates available? I've seen various derpiness from network cards involving IPv6 and sleep. – thrig Mar 19 '17 at 14:43
  • Haven't touched the BIOS for ages... I should probably see if I can update it. I'm not very well informed but is the BIOS involved when resuming from sleep? I thought it ran only on system boot right before e.g. GRUB. – Al.G. Mar 20 '17 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.