1

I have issues with my WiFi driver on my Acer E5 575G notebook.
I have tried to install drivers manually and I have even tried to apt install firmware-realtek and apt install firmware-atheros
I have even tried to manually install drivers from git but with no luck.

Useful information:

neisor@debianneisor:~$ lspci
00:00.0 Host bridge: Intel Corporation Device 1904 (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Device 1916 (rev 07)
00:14.0 USB controller: Intel Corporation Device 9d2f (rev 21)
00:14.2 Signal processing controller: Intel Corporation Device 9d31 (rev 21)
00:15.0 Signal processing controller: Intel Corporation Device 9d60 (rev 21)
00:16.0 Communication controller: Intel Corporation Device 9d3a (rev 21)
00:17.0 SATA controller: Intel Corporation Device 9d03 (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Device 9d18 (rev f1)
00:1d.2 PCI bridge: Intel Corporation Device 9d1a (rev f1)
00:1d.3 PCI bridge: Intel Corporation Device 9d1b (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d48 (rev 21)
00:1f.2 Memory controller: Intel Corporation Device 9d21 (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d70 (rev 21)
00:1f.4 SMBus: Intel Corporation Device 9d23 (rev 21)
01:00.0 3D controller: NVIDIA Corporation Device 179c (rev a2)
03:00.0 Network controller: Qualcomm Atheros Device 0042 (rev 31)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5287 (rev 01)
04:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)

neisor@debianneisor:~$ uname -a
Linux debianneisor 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux

root@debianneisor:/home/neisor# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 8.7 (jessie)
Release:        8.7
Codename:       jessie

Just to make things clear, my ethernet adapter works but my WiFi doesn't. Another thing, my WiFi has always worked out-of-the-box in Fedora and Ubuntu.

Any idea on how to fix it on Debian?

Thank you.

  • "I have tried to install drivers manually and I even tried to apt install firmware-realtek and apt install firmware-atheros" What happened when you tried this? What EXACT error messages did you get? Has your sources list been changed to add "non-free"? Have you Rebooted? – user8779 Mar 19 '17 at 10:57
  • please, post the output of dmesg – mattia.b89 Mar 19 '17 at 12:45
  • @arocheste No errors were shown, everything installed just fine but the functionality did not come to life. Yes, I added the non-free repository too in the sources.list. – rogaloo Mar 19 '17 at 12:47
  • @mattia.b89 dmesg is shown here pastebin.com/ifr0snhG Hope it helps :) Thank you – rogaloo Mar 19 '17 at 12:57
  • Suggestion that it works with an updated kernel. Install Stretch Debian instead? digitz.org/blog/… – user8779 Mar 19 '17 at 21:17
1

The ath10k driver isn't available on debian jessie , you should get it from backports .

Add the following line to your /etc/apt/sources.list:

deb http://httpredir.debian.org/debian jessie-backports main contrib non-free

Search and Install a new kernel from backports:

apt-cache search linux-image
apt-get install linux-image-xxx
apt-get install linux-headers-xxx

Reboot then install the firmware-atheros from backports:

apt-get update
apt-get -t jessie-backports install firmware-atheros
modprobe ath10k

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.