3

My headphone is not being detected on my Linux Mint 18 Sarah. I've already reinstalled it (two or three times), but the problem remains. I also searched, and tried going through a lot of solutions, plenty of which from the Linux Forum. All in vain.

I have dual boot with Windows 10, and my headphone works just fine there. Can anyone help? My PC is an Asus X555U series(with nVidia inside, if this is relevant). The ISO is from the Linux Mint official site.

Update: I've followed dirkt's advice, and saved the output of some commands on pastebin. The link to my pastebin profile is below.

http://pastebin.com/u/CaduUnb

Output of 'aplay-l': Headphone Issue.1

Output of 'pacmd list-sinks': Headphone Issue.2

Output of 'cat /proc/asound/card*/codec#*': Headphone Issue/Debugging alsamixer

  • (1) Please edit question to include (with headphone plugged in) output of aplay -l. Further steps: (2) Check in alsamixer if anything is muted (MM instead of OO, make sure to select right card) that shouldn't be. (3) Check in pavucontrol in the Output Devices tab if there's a port for headphones. Check in the Configuration tab if another configuration helps. For information, you can put the output of pacmd list-sinks in a pastebin. (4) If neither port nor configuration help, put output of cat /proc/asound/card*/codec\#* in a pastebin. – dirkt Mar 19 '17 at 10:26
  • (1) Says -1 option is invalid. (2) Headphone was muted, but I had already checked this a thousand times, changed it, but didn't change a thing. (3) I'll update this comment after I proceed with 3 and 4. I'm guessing Linux is not even detecting there's something plugged in, since the sound keep coming from the Stereo Speakers, and - in sound options -, I don't get the option to change to Headphones. – Caio Eduardo Mar 19 '17 at 15:19
  • (1) That's -l (ell, like list), not -1 (one). (3) Even if nothing is plugged in, normally it's possible to unmute headphones and enable the sound output. I don't know Linux Mint, so I'm not sure what "sound options" in whatever GUI see are based on, but missing options there don't mean anything, and you should be able to switch using lower-level programs. Unless there's a quirk in how your chipset deals with headphones which ALSA doesn't realize, but we'll see this in the output of codec. – dirkt Mar 19 '17 at 17:12
  • (2) Oh!, now I understood what you meant! Yes, it is MM not 00! S/PDIF is also MM. Auto-mute is Disabled. (3,4) I've done it. Gonna update the question. Thanks, dirkt. Hope that helps me get someone to solve my issue. – Caio Eduardo Mar 19 '17 at 17:43
  • Did you manage to solve the issue? I'm having the same problem. Anyway it works if you install pavucontrol and use headphones even though it is reported as unplugged. – barsan-md Apr 21 '17 at 17:07
1

Ok, your Codec looks good. Here's the pin node of your headphone:

Node 0x21 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out
  Control: name="Headphone Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0001001c: OUT HP EAPD Detect
  EAPD 0x2: EAPD
  Pin Default 0x04211020: [Jack] HP Out at Ext Right
    Conn = 1/8, Color = Black
    DefAssociation = 0x2, Sequence = 0x0
  Pin-ctls: 0xc0: OUT HP
  Unsolicited: tag=01, enabled=1
  Power states:  D0 D1 D2 D3 EPSS
  Power: setting=D3, actual=D3
  Connection: 2
     0x02 0x03*

That says you have an ALSA control "Headphone Playback Switch", which is currently muted. Unmute it in alsamixer (press right arrow until you see it, select it, press m), and you should hear something, or at least get an additional port in pavucontrol that you can select to hear something. It also says that it can detect plug events, and currently it's plugged in. To verify that the detection work, run evtest as root, pick the one that looks most similar to "HDA Intel PCH Headphone", and remove/plug in the headphone. You should see the events.

If unmuting the Headphone Playback Switch control doesn't work, please add the output of amixer -c0 contents to the pastebin. One possible complication is that the headphone has an external amplifier ("EAPD"), and that is sometimes controlled by the BIOS or SMM firmware.

Edit: Ok, next step is to make sure the external amplifiers don't interfere. There are cases when the external amplifiers don't come up after hibernation etc. So completely cold boot your laptop with the headphones already plugged in if you haven't done so before, and try directly after boot before doing anything else. I.e., make sure Headphone Playback Switch and Headphone Playback Volume are unmuted. Also make sure in pavucontrol the stream is routed to the correct sink.

Additionally, please provide again the output of pacmd list-sinks in the pastebin after unmuting.

Last thing to try is to enable Auto-Mute Mode, unplug headphones, save a copy of amixer -c0 contents in a temporary file, plug in headphones, again save amixer -c0 contents in a different file, and compare with diff -u.

  • I ran the commands, unmuted my headphones, but, still, pavucontrol did not give the option to them. Sound only comes out from stereo speakers, even with it plugged in. I've uploaded the results of amixer -c0 contents on pastebin. Btw, thanks, in advance. You're giving me hope that it'll work, hahaha – Caio Eduardo Mar 19 '17 at 22:48
  • I checked diff -u, and it gave me nothing. Then I ran diff -s, and it said the files are identical. I also provided the output of pacmd list-sinks on this link: pastebin.com/kaTfMacN – Caio Eduardo Mar 20 '17 at 17:53
  • Hm. Did you get events with evtest? – dirkt Mar 20 '17 at 18:11
  • I had forgot. But now I've just tried it, unplugging/plugging. It didn't show any event on that. Still, the output is on my pastebin. – Caio Eduardo Mar 21 '17 at 2:56
  • I'm running out of ideas now. Best guess is that the external amplifier is controlled from BIOS/SMM/EC whatever, and not powered up. Cold booting with headphone plugged in (to make sure BIOS initializes external amp correctly) didn't show any results? – dirkt Mar 21 '17 at 6:14
0

I had something similar - plugged my headphones, no sound. PA could "see" that the headphones were plugged in. Forcing PA to switch to speakers had sound from both headphones and speakers.

Using alsamixer I confirmed that the headphone output was MM (muted) when they weren't plugged in and 100% when they were - but no sound.

Scrolling across the loads of IFs in alsamixer for the built in sound card I found that loopback was enabled when the headphones were plugged in - disabling that and I had sound from headphones only.

Hope that helps!

0

To add to @am4c130d answer (below this answer):

What he means with the loads of IFs, when using alsamixer is that you use the right-scroll button (or right-arrow) to scroll through the options and until you reach the option 'Auto-mute-mode [...]'. If it is enabled you push the arrow-up button on your keyboard and disable it: 'Auto-Mute Mode [Disabled]'.

Don't do this while having your headphone up. It could be very loud.

0

I had a similiar problem, I removed my laptop ACER Aspire 7560 from office (unplugged the speakers from output headset) into kitchen and some hours later back. After plugging the boxes in at office they did not work, and the onboard speakers didnt switch off after plugging the cable for the boxes to the headset plug. Solution was simple after some tries off rebooting (which served nothing): I run the plugged speakers via headset outlet under audacity (another player program I had availbale), they immidately worked. After that also the normal linux mediaplayer was back on duty.

0

I struggled for hours with an Alienware 15 laptop with the same issue. Plugging in speakers/headphones simply did nothing. I installed Alsa mixer and checked the "HP/Speaker Auto Detect" button which was surprisingly unchecked. Checking that button solved the issue for me. I don't remember the link from this solution idea.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.