2

When I run "postsuper -d ALL" all messages from mailq are deleted. For a few seconds I am able to send emails from terminal just fine. However, even if I just stand still and do nothing after clearing the mailq, after about 20 seconds some new entries starts to show up in the queue, which prevents any other email message to be sent. In other words, if I clear the mail queue, and do nothing, new entries shows in the mail queue... and they prevent me to be able to send new email messages through the server.

I already tried:

  • Restarting the server
  • postfix stop
  • postqueue -f
  • postfix flush
  • postsuper -d ALL deferred

I also tried to: - Uninstall postfix - Uninstall cyrus-sasl - Uninstall cyrus-imapd - Uninstall mailx

But when I re-install them, the issue comes back.

Nothing seems to prevent those new messages to show up on the mail queue again and again every 20 seconds.

How can I fix that?

  • Note: I also tried "postsuper -r ALL incoming" and it did not work. – Fabio Nolasco Mar 18 '17 at 19:01
  • Side note: I also tried to delete all folders related to postfix right after uninstalling it, but that did not fix the issue. – Fabio Nolasco Mar 22 '17 at 15:08
0

I believe the issue was fixed by fixing permissions on the folder:

/var/lib/imap/socket/lmtp

There was also a small difference between the server's hostname and the hostname actually defined on the postfix config file. After those two things were fixed, the postfix was restarted.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.