I would like to try this distribution. I made a bootable USB drive that I was able to use on my laptop, but I can't make it work on my main PC.

Here is a screenshot of what's happening at boot time.

enter image description here

I have to boot with kernel set to 'safe' to have this screen, otherwise I am stuck on a black screen.


Unable to init device /dev/mcelog (rc: -5)

It seems to be related with nouveau driver. I'm not sure it is the reason why the system cannot be initiated. I would rather use the proprietary driver later on anyway.

unable to locate ioapic for gsi 51

Seems to be related to 4.8 and harmless (Source: https://bbs.archlinux.org/viewtopic.php?id=218566)

usb 1-1: device not accepting address 2, error -110

I tried what is advised here, but it was unsuccessful.

I also tried all USB ports.

From the UEFI menu I had two options to boot from my USB stick (Sandisk).

  • UEFI Sandisk
  • Sandisk

According to the one I pick it drives me to two possible screens.

enter image description here
The UEFI option (screen 1)

enter image description here
The non UEFI option (screen 2)

  • If you are in safemode, then you have started to boot Microsoft's windows. Mar 18, 2017 at 11:47
  • Kernel mode is set to 'safe', manjaro offer the possibility to select this option when you boot.
    – zakrapovic
    Mar 18, 2017 at 12:13

3 Answers 3


Pick the UEFI option only if you know exactly what you're doing. So pick the non-UEFI option, select the Start Manjaro Linux option, then follow below instructions.

Select the Live CD entry in the boot menu, press E on your keyboard and replace quiet splash with nomodeset. If you don't find quiet splash, just look for the second last line and place nomodeset after ro.

  • I updated the thread, I do not see where I have the opportunity to add such parameters. There is no grub bootloader so far. thanks anyway for helping
    – zakrapovic
    Mar 18, 2017 at 17:30
  • Updated my answer.
    – Akito
    Mar 18, 2017 at 17:57
  • I have nowhere the opportunity to press E and do such a thing, once I pick Start Manjaro Linux I do not have hand anymore. Maybe it is something you can do with other kind of bootable distro, manjaro is based on arch linux which might include component you are not familiar with.
    – zakrapovic
    Mar 18, 2017 at 18:00
  • I updated the very end of the post so maybe you can help me booting in non UEFI mode form the HDD. thanks
    – zakrapovic
    Mar 18, 2017 at 18:01
  • I can also access the bootable device through grub thanks to my actual linux. From there I might add the parameter you are talking about. here is my actual boot entry : search --fs-uuid --no-floppy --set=root 5DD6-EE22 chainloader (${root})/EFI/boot/bootx64.efi
    – zakrapovic
    Mar 18, 2017 at 18:04

Errors from the non UEFI mode in the end were misleading.
So far the UEFI path led me to blackscreen, but it is actually the one to pick. The problem is that with this grub you cannot modify kernel parameters on the fly by pressing E. Doing it bring a line *initrd=/.../ * with the path to initrd but you cannot scroll to the left or right to get to the options we are looking for. To specify the nomodeset option I had to modify *loader/entries/manjaro-[arch].conf and substitute

nouveau.modeset=1 i915.modeset=1 radeon.modeset=1



By doing that it keep the native resolution and you can see the log going on.
At some point it stopped at line

OK start account service

By doing Ctrl+Alt+F2 you can get to a terminal windows and login as user manjaro pwd manjaro
From there you can acces journal

journalctl -b

And see what went wrong, in my case the driver of my graphic card are not taken into account properly

Apparently nouveau do not handle my graphic card correctly but if you pick non-free driver it can work
In you bootable manjaro USB, in *loader/entries/manjaro-[arch]-nonfree.conf substitute

nouveau.modeset=1 i915.modeset=1 radeon.modeset=1



Reboot in UEFI mode, select Start Manjaro nonfree, and that's it!

  • this worked. i wasn't removing the =1 stuff
    – chovy
    Dec 31, 2020 at 4:12

Try creating your live USB with etcher, it solved the boot issue for me (usb key shown no bootable files): https://etcher.io/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.