I have Debian Jessie and vim terminal text editor. I try to autocomplete a file path in insert mode. When I type ctrl and x simultaneously no path completing is done but two chars are displayed:


I had another Jessie installation two days ago and this worked properly but I had to reinstall Debian. Now path autocompletion doesn't work. How to fix it?

edit: My issue is shown on the gif. I press ctrl+x and no completion happens:

enter image description here

closed as off-topic by Jeff Schaller, Thomas Nyman, Kusalananda, Michael Homer, slm Mar 18 '17 at 21:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Thomas Nyman, Kusalananda, Michael Homer, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Do you mean vi or vim? I don't think vi has autocompletion. – Rio6 Mar 18 '17 at 8:37
  • Yes it's vim. You are right. – trzczy Mar 18 '17 at 8:53
  • Does the problem still happen when starting vim with vim -u NONE ? – thrig Mar 18 '17 at 14:23
  • I installed vim and the problem disappeared. I will test this next time on fresh Debian installation. – trzczy Mar 18 '17 at 14:28

It is actually ^X^F, as in screenshot below:

enter image description here

  • I know how it should work. But in my case pressing ctrl+x makes vim display literally ^X. Need help how to fix it. – trzczy Mar 18 '17 at 9:23
  • @trzczy You're using vi, not vim. This feature is not available in vi. – Kusalananda Mar 18 '17 at 15:49
  • @Kusalananda No, when I typed vi without filename the information appeared that this was VIM. – trzczy Mar 18 '17 at 16:17

I installed vim and it worked

apt-get install vim

edit: This is the solution.

Not the answer you're looking for? Browse other questions tagged or ask your own question.