I've recently decided to replace Windows with Linux Mint 18. I made a bootable USB to install it, I've turned secure boot off. Whenever I try to install it, no matter if I partition things manually or do an automatic install, it always gives me this "grub-efi-amd64​ package failed to install to /target/". I'm running out of ideas on what to do.

Any clues?

2 Answers 2


Make sure you boot the Live CD in UEFI mode by looking for the entry that looks like [UEFI] USB Flash Drive or something similar. Then you can partition everything yourself, but make sure you make one partition formatted as ext4 which has at the very least 700MB of size and mark it as /boot-partition. Then create a partition of size ~400MB, format it as FAT32 and mark it as EFI-partition. And of course you have to make sure the root-partition has enough space anyway.

Also you should make sure to change the partition table to GPT.

But beware of one thing: the first step is crucial. If your machine does not support EFI, then it won't work. You have to make sure to choose the entry saying something like: [UEFI] USB Flash Drive.

  • Okay so this time the installation worked, but there's no bootloader. When I start up, it takes me to my computer's BIOS settings. How do I get it to boot into grub? Commented Mar 17, 2017 at 15:36
  • Are you sure you did everything the EFI way? If yes, then just download rescatux or boot-repair Live CD, boot up into that and follow the easy instructions. Just choose Recommended repair and everything should be fine.
    – Akito
    Commented Mar 17, 2017 at 15:40
  • I got it solved. I had to turn off fast boot, not only secure boot! Commented Mar 17, 2017 at 17:35
  • 1
    That's weird. I never had an issue with that, regarding Linux boot ups.
    – Akito
    Commented Mar 17, 2017 at 17:36

I faced the same problem when I installed Mint 18.3 from LiveCD alongside with Windows 10. The installation failed when it tried to put grub on /dev/sda (in my case). I put attention that:

  • When installation is running from LiveCD then no drives (/dev/sda, /dev/sdb etc) available. I believe that's the main reason for grub installation failure.
  • When I run GParted from LiveCD I see the same effect: /dev/sda, /dev/sdb etc become unavailable. However, when I exit GParted, the devices become available again.

So, my steps were:

  1. Run Mint installation from within LiveCD session => disk devices become unavailable.
  2. While the installation is running, run GParted and wait while GParted accesses disk devices list => disk devices are still unavailable.
  3. Quit Gparted => disk devices become available!
  4. By the end of Mint installation it tries to install grub on /dev/sda and... voilà! Installation completed successfully!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .