3

I'm using Arch linux and I have got two video cards in a laptop without an external monitor. Video cards are intel and nvidia 720M. Intel is used by default and nvidia drivers are installed (I think). Here is the output from inxi -G:

Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]
           Display Server: X.Org 1.19.2 driver: modesetting
           Resolution: 1366x768@60.06hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile
           GLX Version: 3.0 Mesa 17.0.1

And here is the output from egrep 'EE|WW' /var/log/Xorg.0.log:

[    23.642] Current Operating System: Linux redshift 4.10.2-1-ARCH #1 SMP PREEMPT Mon Mar 13 17:13:41 CET 2017 x86_64
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    23.864] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    23.865] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    23.865] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    23.902] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    24.296] (WW) Warning, couldn't open module intel
[    24.296] (EE) Failed to load module "intel" (module does not exist, 0)
[    24.318] (WW) Warning, couldn't open module nv
[    24.318] (EE) Failed to load module "nv" (module does not exist, 0)
[    24.318] (WW) Warning, couldn't open module fbdev
[    24.318] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    24.319] (WW) Warning, couldn't open module vesa
[    24.319] (EE) Failed to load module "vesa" (module does not exist, 0)
[    24.351] (WW) Falling back to old probe method for modesetting

How do I use nvidia as my default video card? I use xfce as my desktop, if that's relevant.

  • There is no nvidia-driver. – user192526 Mar 16 '17 at 19:01
  • Not sure how it works in Arch linux, but in general, you can create/edit an xorg.conf to force the default drivers and card you want. Usually the location is /etc/X11/xorg.conf, google and man Xorg, man xorg.conf etc. for details. – dirkt Mar 17 '17 at 9:53
  • @bahamut, there are 2 NVIDIA drivers... One from NVIDIA and the open source alternatieve nouveau. – switch87 Mar 17 '17 at 13:06
0

I do not use Arch so I do not know if they provide you with a installation package, but the easiest way to get this done is by installing the official nvidia drivers, they provide a tray icon to switch between the two cards.

Linkt to driver download

edit:

In arch you have to install the settings tool separately:

https://www.archlinux.org/packages/?name=nvidia-settings

  • 1. The OP states they've already installed the drivers. 2. Installing the proprietary drivers does not provide any such tray icon. What you are referring to is probably specific to whatever distribution and/or desktop environment you are using. – terdon Mar 16 '17 at 18:30
  • He did not say he installed the driver. The tray icon is not included but is available for arch (see edit) – switch87 Mar 17 '17 at 13:09
  • Yes they did: "and nvidia drivers are installed (I think)." Thanks for the edit, but are you sure that this tool you mention comes with nvidia-settings? It might, but I have been using nvidia cards and nvidia-setting for years and have never seen this thing. I think it's probably something specific to your distribution and/or desktop environment. – terdon Mar 17 '17 at 13:13
  • It is part of nvidia settings. I use the mate desktop and awesome wm, it works in both so should work in others two. He thinks the driver is installed, so he did not do it manually, so is is not installed if he uses arch. sometimes you have to think further than what is written ;) – switch87 Mar 17 '17 at 13:41
  • OK. Maybe they've added this recently. – terdon Mar 17 '17 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy