0

On my laptop, I use KDE 4 on Linux Mint 17.3. I have an Nvidia NVS 5400M, along with the integrated Intel HD graphics. I have the latest Nvidia binary driver installed, 367.57, and I've got the Nvidia GPU selected. I do not use bumblebee.

I use two external monitors at work and at home, one connected via VGA, and one connected via mDP adapted to DVI. If I switch to Intel graphics, the mDP output is no longer functional.

With this setup, multiple monitor support is somewhat flaky. When I dock or plug in the external monitors, I usually have to fiddle a bit in order to get everything working properly. I'm used to this, I know it's because of bugs in Intel's driver along with bugs in KDE (and maybe in X, too). I'll wait patiently for these to get fixed.

But at work, I recently got two new monitors. The weird thing that's happening now (and it's only happening at work), is that my desktop spans all three monitors. My panel stretches across all three, as does my wallpaper, and when I maximize or full-screen windows, they do, too. I have a huge, 5760 x 1080 desktop.

When I search, I see old forum posts from people asking for this feature, and other people telling them that it's not supported. Well, it looks like it must be supported now, but how do I turn it off?

0

Install arandr or one derivative. Try to configure the desktop setting accordingly in one of these programs. You can set one monitor as the primary which will be the only one having a panel. Also are you sure there is no KDE setting for that? Sadly I can't help much with KDE configuration because I never use this DE, but I read that it is highly customizable by default, so maybe there is a settings option that solves this issue even more proficiently.

| improve this answer | |
  • I don't really see anything in arandr's options that affects the desktop layout, just the screen layout, similarly to the Display KDE control module. Compare image.ibb.co/i9iNWF/arandr.png and image.ibb.co/e17MQa/display.png. – P Daddy Mar 16 '17 at 17:36
  • The display KDE control has a favourite button, which you determine the primary screen with I suppose. Did you try to turn off both side screens and then turn on each one by one? Also can't you change the size of the panel in edit mode? As far as I recall the panel has an elaborate edit mode which allows such things. – Akito Mar 17 '17 at 8:53
  • The star does indeed determine the primary screen, although it has no effect when the desktop stretches across all three screens. Yes, I could manually (and imperfectly) resize the panels (I have one on each screen, with each one's task manager normally only showing windows on that screen) by dragging their sizing handles, but in addition to being tedious, it wouldn't address the larger problem of windows spanning multiple screens. I constantly have to manually move and size them to keep them on one screen. – P Daddy Mar 17 '17 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.