3

When urxvt is launched directly a nice looking font is used:

plain

But when it is launched by x-terminal-emulator an ugly cramped font is used:

through x-terminal-emulator

But x-terminal-emulator is just a symlink which eventually resolves to /usr/bin/urxvt:

ls /usr/bin/x-terminal-emulator -l         
lrwxrwxrwx 1 root root 37 Jun 19  2016 /usr/bin/x-terminal-emulator -> /etc/alternatives/x-terminal-emulator

ls /etc/alternatives/x-terminal-emulator -l
lrwxrwxrwx 1 root root 14 Mar 16 08:14 /etc/alternatives/x-terminal-emulator -> /usr/bin/urxvt

and

which urxvt
/usr/bin/urxvt

If it matters I'm running Ubuntu 16.04, with urxvt version 9.21.

2 Answers 2

4

It's probably seeing the symbolic link as an alias which changes the instance name, and using that as a (mis)clue is missing the X resource file (and using just its fallback resources).

1
  • Yes! Thank you! It turns out that my font settings were urxvt*font: ... but it should have been URxvt*font: .... For any future bug hunters: from what I can understand in Xresource configuration urxvt is a program name, so it doesn't apply when the $0 is anything other urxvt (e.g. when it's x-terminal-emulator). In contrast URxvt is a "class" name so it applies for all programs.
    – dshepherd
    Commented Mar 16, 2017 at 14:30
0

After googling without no help (everyone indicates use of URxvt on Xresources but on mine only works as urxvt) I supposed that it follows the instance name that is derived from the start process.

I tried in .Xresources:

x-terminal-emulator*font: xft:Victor Mono:pixelsize=16

And then ran xrdb -merge ~/.Xresources

It worked.

Observe that I don't know if this is the best way. It worked. And I think that use the x-terminal-emulator when calling a terminal is a more standard way through many desktop environments.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .