0

I'm trying to add a system_filer on a single file configuration in Exim. The problems is that when running update-exim4.conf I'm getting option "system_filter" unknown. I have searched the file if there are macros to enable this option without success. How can this be achieved?

1
  • Exim has many sections in its configuration file. Where are you setting that option? If it's in the wrong location, this won't work. Commented Mar 16, 2017 at 6:52

1 Answer 1

2

The exim.conf file has a few sections. These start with the keyword begin followed by the section name; e.g., the acl section starts at the line begin acl, and ends at the next section (or the end of the file, whichever is first).

There is one extra section, the one that holds global options. This section does not start with a begin keyword; instead, it starts at the beginning of the file, and ends at the first begin keyword (i.e., at the next section).

The system_filter setting is a global setting, and therefore must be set in the global section of the file. Since you state that you put it at the end of the file, you did not do so.

Just place it somewhere near the top of the file, before the first line that starts with begin. It will work then.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .