2

I have a custom Debian repository deployed with no translation packages which I created using reprepro utility. Everytime apt-get update is run I see requests to i18n packages which I don't have and hence 404 is returned back to clients. This hasn't been a problem so far, but it seems like a misconfiguration issue that should be addressed.

I managed to stop apt-get from downloading all translations by putting these lines (thanks to a tip similar to this one)

Acquire::Languages {
 "none";
}

to /etc/apt/apt.conf.d/99languages

I want to this to work only for my repo. I've stumbled upon similar problems with setting up repository-specific proxies. These problems have been solved with adding a repository URI before "none" but this doesn't seem to do the job for Languages options.

I'll be very thankful to anyone who might recommend a proper solution.

I'm using a Debian Jessie-based distribution.

3
  • Are you using a custom Debian repository in Ubuntu? Mar 14, 2017 at 17:40
  • @ElderGeek I'm using a modified Ubuntu, so lsb_release won't really shed any light on the problem. lsb_release modules are not included. Guys, correct me if I'm wrong. I guess this question could also be asked on ServerFault or *Unix & Linux *but I reckoned AskUbuntu is more applicable here as it's a package management issue that is relevant to Ubuntu. And therefore more people will benefit from it. Mar 15, 2017 at 7:33
  • @staroselskii in any case, I poked around the manpage, and the only mention of server-specific settings are for http/https/ftp.
    – muru
    Mar 15, 2017 at 13:33

1 Answer 1

0

Add [lang=none] to your repository's entry in /etc/apt/sources.list or the file for it in /etc/apt/sources.list.d. For example, the repository:

deb http://deb.debian.org/debian buster main contrib non-free

becomes:

deb [lang=none] http://deb.debian.org/debian buster main contrib non-free

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .