0

Good evening,

I wanted to download GHDL so I did this command :

sudo apt-get install ghdl

But I have a message who said that no version of the GHDL package is disponible [available — translated spanish/french to english], but that it exists in the database. And they said that the package GHDL doesn't have a version who can be installed.

I try this command too :

sudo apt-get install ghdl gtkwave

But I get the same message. So, my question is : how can I download GHDL? I'm on Ubuntu, with the 16.04 version.

Thanks in advance for any help.

closed as off-topic by Kiwy, Jeff Schaller, Anthony Geoghegan, GAD3R, Timothy Martin Apr 24 '18 at 21:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Kiwy, Jeff Schaller, Anthony Geoghegan, GAD3R, Timothy Martin
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    When was the last time you run apt update? – ddnomad Mar 15 '17 at 17:58
  • 1
    Can you show the error message in the question. – ctrl-alt-delor Mar 15 '17 at 19:39
  • I install Ubuntu last week and did the update. But in case I did it now and nothing change. The error is in French, but I can put it here (but now I did the instruction from the other answer below and the error change a little bit) : – Hix Mar 16 '17 at 9:46
  • Lecture des listes de paquets... Fait Construction de l'arbre des dépendances Lecture des informations d'état... Fait ghdl is already the newest version (0.33-1ubuntu1). Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes : Les paquets suivants contiennent des dépendances non satisfaites : ghdl : Dépend: libgnat-4.8 (>= 4.8.2-8ubuntu3) mais il n'est pas installable E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet (ou indiquez une solution). – Hix Mar 16 '17 at 9:46
1

Another way of installing GHDL on your Ubuntu is to download the package manually and install it using the dpkg command. Here is how you can do this:

Go to: https://github.com/tgingold/ghdl/releases/tag/v0.33

Download the ghdl_0.33-1ubuntu1_amd64.deb package directly onto your Ubuntu by executing the following command:

wget https://github.com/tgingold/ghdl/releases/download/v0.33/ghdl_0.33-1ubuntu1_amd64.deb

After it finished downloading, you can execute the following command to install it:

sudo dpkg --install ghdl_0.33-1ubuntu1_amd64.deb

  • I did the first command and it was okay, but with the second they said that the package libgnat-4.8 isn't install. So I did sudo apt-get install libgnat-4.8 But I meet the same error that for downloading ghdl : that no version of this package is disponible. This package is important? – Hix Mar 16 '17 at 9:43
  • @Hix Looks like that your /etc/apt/sources.list file is corrupted. Can you copy/paste the content of that file here? – amdjml Mar 17 '17 at 14:34
  • There is juste a file for skype inside (skye-stable.list) and inside this file its written : deb [arch=amd64] https://repo.skype.com/deb stable main but I don't think that it was the thing that you speak about – Hix Mar 18 '17 at 10:04
  • @Hix Take a look at this link. It will show you what should be in the \etc\apt\sources.list file. Once you did that, make sure you run sudo apt update and then try installing the package you want. – amdjml Mar 20 '17 at 15:23
  • 1
    @Hix you can answer you own question explaining what you did to solve it and then accept it as the answer. – Katu Mar 6 '18 at 9:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.