0

I'm trying to install the ceph-common package using yum:

yum install ceph-common 

in a recently created RHEL AMI instances, with instance version:

cat /proc/version
Linux version 3.10.0-514.10.2.el7.x86_64 (mockbuild@x86-039.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Mon Feb 20 02:37:52 EST 2017

This is failing due to a dependency problem

sudo yum install ceph-common
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Resolving Dependencies
--> Running transaction check
---> Package ceph-common.x86_64 1:0.80.8-17.el7cp will be updated
--> Processing Dependency: ceph-common = 1:0.80.8 for package: 1:ceph-radosgw-0.80.8-17.el7cp.x86_64
---> Package ceph-common.x86_64 1:0.94.5-1.el7 will be an update
--> Processing Dependency: librados2 = 1:0.94.5-1.el7 for package: 1:ceph-common-0.94.5-1.el7.x86_64
--> Processing Dependency: librbd1 = 1:0.94.5-1.el7 for package: 1:ceph-common-0.94.5-1.el7.x86_64
--> Processing Dependency: python-rados = 1:0.94.5-1.el7 for package: 1:ceph-common-0.94.5-1.el7.x86_64
--> Processing Dependency: python-rbd = 1:0.94.5-1.el7 for package: 1:ceph-common-0.94.5-1.el7.x86_64
--> Processing Dependency: cryptsetup for package: 1:ceph-common-0.94.5-1.el7.x86_64
--> Processing Dependency: hdparm for package: 1:ceph-common-0.94.5-1.el7.x86_64
--> Running transaction check
---> Package ceph-common.x86_64 1:0.80.8-17.el7cp will be updated
--> Processing Dependency: ceph-common = 1:0.80.8 for package: 1:ceph-radosgw-0.80.8-17.el7cp.x86_64
---> Package cryptsetup.x86_64 0:1.7.2-1.el7 will be installed
---> Package hdparm.x86_64 0:9.43-5.el7 will be installed
---> Package librados2.x86_64 1:0.80.8-17.el7cp will be updated
--> Processing Dependency: librados2 = 1:0.80.8 for package: 1:ceph-radosgw-0.80.8-17.el7cp.x86_64
---> Package librados2.x86_64 1:0.94.5-1.el7 will be an update
---> Package librbd1.x86_64 1:0.80.8-17.el7cp will be updated
---> Package librbd1.x86_64 1:0.94.5-1.el7 will be an update
---> Package python-rados.x86_64 1:0.80.8-17.el7cp will be updated
---> Package python-rados.x86_64 1:0.94.5-1.el7 will be an update
---> Package python-rbd.x86_64 1:0.80.8-17.el7cp will be updated
---> Package python-rbd.x86_64 1:0.94.5-1.el7 will be an update
--> Finished Dependency Resolution
Error: Package: 1:ceph-radosgw-0.80.8-17.el7cp.x86_64 (@rhui-REGION-rhel-server-rh-common)
           Requires: ceph-common = 1:0.80.8
           Removing: 1:ceph-common-0.80.8-17.el7cp.x86_64 (@rhui-REGION-rhel-server-rh-common)
               ceph-common = 1:0.80.8-17.el7cp
           Updated By: 1:ceph-common-0.94.5-1.el7.x86_64 (rhui-REGION-rhel-server-releases)
               ceph-common = 1:0.94.5-1.el7
           Available: 1:ceph-common-0.80.7-2.el7.x86_64 (rhui-REGION-rhel-server-releases)
               ceph-common = 1:0.80.7-2.el7
           Available: 1:ceph-common-0.80.7-3.el7.x86_64 (rhui-REGION-rhel-server-releases)
               ceph-common = 1:0.80.7-3.el7
           Available: 1:ceph-common-0.80.8-6.el7cp.x86_64 (rhui-REGION-rhel-server-rh-common)
               ceph-common = 1:0.80.8-6.el7cp
           Available: 1:ceph-common-0.80.8-7.el7cp.x86_64 (rhui-REGION-rhel-server-rh-common)
               ceph-common = 1:0.80.8-7.el7cp
           Available: 1:ceph-common-0.80.8-15.el7cp.x86_64 (rhui-REGION-rhel-server-rh-common)
               ceph-common = 1:0.80.8-15.el7cp
Error: Package: 1:ceph-radosgw-0.80.8-17.el7cp.x86_64 (@rhui-REGION-rhel-server-rh-common)
           Requires: librados2 = 1:0.80.8
           Removing: 1:librados2-0.80.8-17.el7cp.x86_64 (@rhui-REGION-rhel-server-rh-common)
               librados2 = 1:0.80.8-17.el7cp
           Updated By: 1:librados2-0.94.5-1.el7.x86_64 (rhui-REGION-rhel-server-releases)
               librados2 = 1:0.94.5-1.el7
           Available: 1:librados2-0.80.7-2.el7.x86_64 (rhui-REGION-rhel-server-releases)
               librados2 = 1:0.80.7-2.el7
           Available: 1:librados2-0.80.7-3.el7.x86_64 (rhui-REGION-rhel-server-releases)
               librados2 = 1:0.80.7-3.el7
           Available: 1:librados2-0.80.8-6.el7cp.x86_64 (rhui-REGION-rhel-server-rh-common)
               librados2 = 1:0.80.8-6.el7cp
           Available: 1:librados2-0.80.8-7.el7cp.x86_64 (rhui-REGION-rhel-server-rh-common)
               librados2 = 1:0.80.8-7.el7cp
           Available: 1:librados2-0.80.8-15.el7cp.x86_64 (rhui-REGION-rhel-server-rh-common)
               librados2 = 1:0.80.8-15.el7cp
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

How can I install ceph-common in this Red Hat instance?

closed as off-topic by Thomas Nyman, Jeff Schaller, Michael Homer, slm Mar 16 '17 at 1:59

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Thomas Nyman, Jeff Schaller, Michael Homer, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

1

Solved with a

yum clean all
yum reinstall ceph-common

Not the answer you're looking for? Browse other questions tagged or ask your own question.