5

i can't get two finger scrolling to work for anything on Linux mint 12 64bit.... hp dv7 laptop. the hardware definitely supports it as it works just fine on my windows partition.

following the instructions here: http://robert.orzanna.de/2011/06/06/enable-two-finger-scroll-in-linux-mint-11-and-ubuntu-11-04/

i created a

/usr/share/X11/xorg.conf.d/50-twofingerscroll.conf

file and add the following information:

Section "InputClass"
Identifier "touchpad catchall"
MatchProduct "SynPS/2 Synaptics TouchPad"
MatchDevicePath "/dev/input/event*"
Option "VertTwoFingerScroll" "on"
Option "HorizTwoFingerScroll" "on"
Option "EmulateTwoFingerMinW" "8"
Option "EmulateTwoFingerMinZ" "40"
EndSection

based on this link:

http://jaisejames.wordpress.com/2011/11/29/to-enable-touchpad-tap-on-click-two-finger-scroll-in-linux-for-laptop-users/

i also tried a slightly different conf file

Section "InputClass"
      Identifier "touchpad catchall"
      Driver "synaptics"
      MatchIsTouchpad "on"
      MatchDevicePath "/dev/input/event*"
      Option "HorizScrollDelta" "0"
      Option "TapButton1" "1"
      Option "TapButton2" "2"
      Option "RBCornerButton" "3"
      Option "VertTwoFingerScroll" "1"
EndSection

i've also been to Settings > Mouse >Touchpad and enabled two-finger scrolling. this does nothing but kills all scrolling since edge-scrolling is no longer enabled.

i've also installed gpointing device settings and tried enabling it that way per the instructions here: http://craiglayne.com/linux-mint-enable-two-finger-scrolling-multitouch/

and i still can't get two finger scrolling to work. this is driving me crazy, not to mention i still have about 2-3 other problems with mint while trying to make the switch away from windows.

any further ideas? am i missing something obvious? let me know if you need any more information from me.

edit:

the following terminal commands DO finally enable two-finger scrolling. however, they are lost every time i reboot.

synclient VertTwoFingerScroll=1
synclient HorizTwoFingerScroll=1
synclient EmulateTwoFingerMinW=5
synclient EmulateTwoFingerMinZ=48

I found this xorg configuration that definitely works on my Samsung Series 7 for enabling the clickpad! https://gist.github.com/2382480

2
  • The edit about synclient enables it for me! The only issue now is to find out how to disable the touchpad while I'm typing. Thanks!!
    – Alex W
    Commented Jun 20, 2013 at 0:38
  • For what it's worth: This works automatically in newer versions of Linux Mint. Commented Dec 4, 2014 at 10:03

3 Answers 3

2

Don't modify /usr/share/X11/xorg.conf.d/50-twofingerscroll.conf. Generally speaking, never modify files under /usr, except under /usr/local. These files are under the control by the package management system. The configuration files that you can edit are under /etc.

By default, /etc/X11/xorg.conf, the configuration file for the X server (the part of the GUI that talks to the hardware), does not exist. If you want to customize it, you first need to create a file with suitable contents. Run this command from a text console (only if /etc/X11/xorg.conf doesn't exist already!):

sudo sh -c 'Xorg -configure >/etc/X11/xorg.conf'

See Howto find my xorg.conf. Where is it? and the Ubuntu wiki for more information.

Once you've created the file, you can add that InputClass section.

Alternatively, you could arrange for synclient to run whenever you log in. This would make the two-finger scrolling a per-user setting rather than a system-wide setting. See Is there a standard way to have a program start when a user logs in on Linux?; Auto running bash script on login

6
  • i do have a xorg.conf but not a xorg.conf.d folder. i tried putting the inputClass secion into xorg.conf but on reboot only got a black screen. have to jet right this second, but will look more closely at your links later. Commented Mar 27, 2012 at 23:51
  • well i did a reinstall last night, and that solved a different problem i was having (sound icon and usb sound) but still leaves this one. running your sudo command returns: /etc/X11/xorg.conf: Permission denied the links seem to indicate that i can't run that while X is active Commented Mar 28, 2012 at 13:35
  • @helgatheviking Sorry, the redirection should have been within the scope of sudo (see my edit). Be sure to check that you still have no /etc/X11/xorg.conf before running that command, since it would be overwritten. If you want to review the output of Xorg -configure, you can write it to a different file. Commented Mar 28, 2012 at 22:57
  • great thanks! according to : wiki.archlinux.org/index.php/Touchpad_Synaptics i shouldn't edit xorg.conf but instead put things in a xorg.conf.d/ directory, which i tried to no avail. figured it was worth a shot even though i know that arch is a different distro. also i did a reinstall, which fixed my sound icon troubles, but now the synclient commands don't even seem to enable the two-finger scrolling anymore like they used to, so the startup script idea wasn't working either. grr... pulls hair! Commented Mar 29, 2012 at 13:16
  • @helgatheviking If your system has an xorg.conf.d, use it. It's relatively new, not all distributions have it. You may need to allow synclient in xorg.conf, see bbs.archlinux.org/viewtopic.php?id=115196 Commented Mar 29, 2012 at 21:51
1

/usr/share/X11/xorg.conf.d/foo.conf is for examples, afaik. Copy your edited file to /etc/X11/xorg.conf.d/foo.conf and reboot.

(Btw, came here via Google because my Synaptics touchpad suddenly has no two-finger-scroll after the last dist-upgrade. Don't know reason, didnt need .conf before.)

3
  • i read some of the .conf files in the /usr/share/X11/xorg.conf.d folder and they do seem to indicate examples. but there is no /etc/X11/xorg.conf.d folder, are the changes meant to go in /etc/X11/xorg.conf ? Commented Mar 27, 2012 at 19:49
  • the answer was definitely no. got a black screen had to boot into a live session and restore the copy i had made of xorg.conf. i did get this working once with some synclient commands but it didn't "stick" between reboots Commented Mar 27, 2012 at 20:21
  • @helgatheviking If you have no /etc/X11/xorg.conf.d, you need to edit /etc/X11/xorg.conf, and first you have to make one; see my answer. Commented Mar 27, 2012 at 22:10
1

As mentioned on: http://www.maketecheasier.com/enable-two-finger-scrolling-in-linux-mint/:

  • Go to Mouse and Touchpad settings
  • Choose the Touchpad tab
  • Under the Scrolling section, choose Panel Layout
  • Select "Two Panel Scrolling"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .