0

I have just created a fresh boot of Kali Linux in order to begin learning penetration testing and security vulnerabilities so hopefully I can find a few 0days, then sell information on them to businesses and governmental organizations, as I understand there are a few now who are interested in acquiring these in a legitimate commercial context.

For this I assume I will benefit from having the latest version of Metasploit for testing. However, when I run apt-get upgrade the update process fails with errors:

E: Failed to fetch http://ftp.hands.com/kali/pool/main/m/metasploit-framework/metasploit-framework_4.14.1-0kali1_amd64.deb  Hash Sum mismatch
   Hashes of expected file:
    - SHA256:5a3f9ee9247a9f32f53873d623c6b275bb11eafa95381aa9d6ecc9724e17518c
    - SHA1:df8606fdc1edb4b4b7f36e068d0789bd0d7289e0 [weak]
    - MD5Sum:677eef194091cfb557219e446d87d753 [weak]
    - Checksum-FileSize:71593968 [weak]
   Hashes of received file:
    - SHA256:c1068062a2da53e1ff1444360720ab4b787d058197e0ca568b330d9fd12fae4e
    - SHA1:900394222f17ddcfd52284b3f0eeeb391ad1089a [weak]
    - MD5Sum:29f15c23a3932e868157a291e44a2720 [weak]
    - Checksum-FileSize:71593968 [weak]
   Last modification reported: Thu, 09 Mar 2017 09:03:20 +0000

Adding the --fix-missing flag seems to cause the upgrade process to proceed further, so I think the system has otherwise now been properly updated, but it still eventually quits out with the same error message. Of course I am wary (to say the least!) about attempting to download an updated version of Metasploit from unofficial sources... but it also seems odd that the default repo is giving a hash sum mismatch.

Does anyone have an idea of what's going wrong here and what the correct methodology is to go about fixing it?

(Current result of running cat /etc/issue

Kali GNU/Linux Rolling \n \l

)

1

I solved this by running msfupdate as a separate command. Once I had done so I ran apt-get update followed by apt-get upgrade again, and this time the upgrade proceeded.

0

Try this on your terminal:

# apt-get clean
# rm -rf /var/lib/apt/lists/*
# apt-get update

I hope this fixes your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.