1

Linux Mint 18.1 ships with pulseaudio version 8.0 as sound system. On linuxmint 17.3 I have version 4.0 and /etc/init/pulseaudio.conf file where pulseadio is configure to get started with line

start on runlevel [2345]

Copying file to /etc/init did not work. I need this because of multiseat configuration.

3
  • Controll with ps ps -ef | grep pulse if it is realy not running. – user192526 Mar 15 '17 at 15:46
  • nope, it is not running. – TadejP Mar 17 '17 at 18:28
  • dpkg -l | grep pulse – user192526 Mar 18 '17 at 10:21
0

Problem was in system.pa. I found in manual that in system wide daemon configuration should not use automatic detection.

from pulseaudio manual pages:

   --disallow-module-loading[=BOOL]
          Disallow module loading after startup. This is a security feature since it disallows additional module loading during runtime and on user request. It is highly recommended when --system is used (see above). Note however, that this breaks certain fea‐
          tures like automatic module loading on hot plug.

So I disabled (commented) lines from system.pa

    ### Automatically load driver modules depending on the hardware available
    #.ifexists module-udev-detect.so
    #load-module module-udev-detect
    #.else
    #### Use the static hardware detection module (for systems that lack udev/hal support)
    #load-module module-detect
    #.endif

and now works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.