1

I am on Ubuntu 16.04 LTS, Dell XPS 15 9550.

Since one week ago (which probably matches last kernel update), every time I wake up my Laptop from suspend-mode, it correctly connects to the WiFi, but then it can't resolve any hostname (Google Chrome raises "DNS FINISHED BAD_CONFIG" and even ssh can't resolve server names).

This happen only when waking laptop up from suspend-mode. If I run

sudo service network-manager restart

then everything comes back to normal. I really have no idea of what's happening. Config or sys changes may be occurred only through automatic updates (kernel updates included).

P.S. I've already tried to reset resolvconf when the problem occurs, but no luck.

Thank you.

EDIT

just found this in syslog

brcmfmac 0000:02:00.0: Direct firmware load for brcm/brcmfmac43602-pcie.txt failed with error -2

The strange thing is that I have an brcm/brcmfmac43602-pcie.bin in /lib/firmware , but it has extension .bin as all others drivers, so I don't know why the kernel is searching for an .txt file.

0

I have the same issue on Ubuntu 16.04.

I fixed it by disabling dnsmasq in network manager configuration

  1. commenting out dns=dnsmasq in /etc/NetworkManager/NetworkManager.conf
  2. sudo service network-manager restart

(I found this workaround on askubuntu)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.