3

On a Toshiba Satellite running Windows 8.1 I installed Fedora 22 as a dual boot setup. It worked fine. The hard drive died, so I bought a new 500GB ssd drive and ordered a recovery usb from Toshiba. I can install Windows fine on it, boot into it, shrink the volume, boot from a LiveCD Fedora USB, and install Fedora 25 into the new space. However, once I do that last step I can no longer boot into Windows from the boot menu, although I can still boot into Fedora. The error I keep getting is:

BLInitializeLibrary failed 0xc0000017

Nothing I have found helps. The Fedora 25 usb was created using Gnome Disk Utility, which from what I understand means that it would be UEFI bootable. Not booting the usb in UEFI mode is one of the possible sources of this issue, but I do not know how to check whether or not grub is in UEFI or not. Is there a way to diagnose or fix this issue? I am fine with starting over, as I have restarted this whole process at least 3 times so far.

Edit: I just verified that the Fedora installation was in UEFI mode.

Edit #2: I was able to do a dual boot installation with a Fedora 22 usb stick, with the thought that if that worked I could just upgrade Fedora afterwards. However, the upgrade did not work, I am assuming because F22 is too old. I will try again with 24, and if that does not work 23. I was able to boot into both F22 and Windows after the installation though, so hopefully this is a Fedora 25 LiveCD image issue only.

1 Answer 1

1

Ok, so through much trial and error and reading, I finally stumbled on this solution. I edited the Windows menu in grub, and changed the last line from:

chainloader /EFI/Microsoft/Boot/bootmgfw.efi

to be

chainloader (hd0,2)/EFI/Microsoft/Boot/bootmgfw.efi

And Windows loaded. This is on the Fedora 24 installation, which gave the identical error as the 25 did, so I am guessing the fix will work for both.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .