1

I've run into this problem which is weird. I'm using Debian jessie and I have setup clamav to listen also on port 3310 with the TCPSocket 3310 option.

After saving the changes to the config file I restart the daemon with service clamav-daemon restart and check if its listening on port 3310 with lsof -i tcp:3310 and it is not.

If I run the daemon manually with clamd --config=/etc/clamav/clamd.conf the everything works perfectly. I have tried to check if there is a /etc/defaults/clam script but there is none. Where can I set the preferences for the startup script to use the config file?

2

dpkg-reconfigure clamav-daemon and make your Configuration over this cli-interface.

lsof -i tcp:3310 COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME systemd 1 root 28u IPv6 356619 0t0 TCP *:3310 (LISTEN) clamd 2503 clamav 3u IPv6 356619 0t0 TCP *:3310 (LISTEN)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.