0

I do have a Supermicro X11SBA-LN4F running Debian stretch RC2.

This board has an AST2400 BMC and an N3700 processor. So, the board got two video cards - one via ast and one via i915. This results in an ast driver being loaded for frame buffer (fb0) and an i915 driver being loaded for frame buffer (fb1).

The screen of the primary ast becomes blank while booting. This happens immediately after the boot message from fsck.

I use IPMI (BMC) to connect to the machine and this is really needed. And there I get a blank remote console. Keyboard input is possible, but it is blank.

I tried all sorts of kernel command lines with modeset, acpi etc. Nothing helped. When I do acpi=off or i915.modeset=0 that the frame buffer for i915 will not be loaded. (acpi=off does not boot, modeset works but then there is no frame buffer for fb1.)

I can re-animate that ast remote console with the command "vbetool dpms on" while ast and i915 fb are both loaded but only for a few seconds! Then it gets magically blanked again. What is happening here? It could be a solution if I am able to find what reverses the "dpms off" in background. I also tried a small script that sends "dpms off" every few seconds but this does not "refresh" the timeout that blanks the screen again, so it will be blank for a few seconds.

Does anyone have a setup with IPMI and a monitor at the HDMI port on that board working correctly?

Can anyone please tell me what reverses the vbetool dpmi command in background or how I can make "dpmi on" persistent? dpmi on is the only thing I can see that helps. Maybe there are other ways...

What do I want as a result? The monitor at i915 is only needed to display syslog stuff. Maybe there is another way to make that happen, means without a frame buffer for i915, because then, the ast frame buffer works and lspci sees the Intel graphics controller (but without fb).

I thank you for any help!

-rvt-

  • If you have multiple graphic chipset on your MB, you can start by only activating one at a time from the BIOS. There are options to select which chipset to enable or not in there, along with plenty other options. May not be the solution, but it may help investigating the issue. – fduff Mar 14 '17 at 7:32
0

Ok, I found a way. It is NO SOLUTION. I do not understand why this works. But it works. I am sure it will not work forever.

I fiddled around and found out that the following sequence does what I want: vbetool dpms on con2fbmap 2 1 con2fbmap 2 0 vbetool dpms on

Now I tried to run that at startup. But as very often, it does not run (means makes nothing). I believe that this is a result of systemd - I had this many times with other startup scripts, too (e.g. ntpd on DCF77 hardware). Even a @reboot in cron does not work. In systemd there is the setting for backlight (in /lib/systemd/system). I just replaced their program with my script and that works - and it is pretty early in startup sequence.

This is embarrassing. I know.

So, if someone knows a better way -a real solution-, please tell me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.