5

I just installed Arch Linux recently and have noticed some odd behavior with the network printer (a Samsung C1860FW model). I have CUPS connected to the printer with IPP and am using a PPD from FooMatic.

Whenever I log in or plug in a flash drive or a USB device, the printer wakes up. Nothing prints, but the printer's touchscreen comes on and it warms up and prepares to print, the same as if I had pressed the power button to wake it up from sleep mode. I changed CUPS logging to debug level and run udisksctl monitor but nothing relevant shows up. However, logging into the console doesn't trigger this; only logging into Plasma. (I don't have any other desktops installed.)

This happens when I plug devices into the PC (back or front ports doesn't seem to matter).

The PC is connected with Ethernet/CAT5e; printer with WiFi. Both are connected directly to the gateway, there's a switch connected too but it's not in use.

The printer includes the "SyncThru Web Service." I can change the length of time that the printer stays warmed up but not what actions cause it to wake up.

EDIT: Using Wireshark, the packets are going to port 9400 TCP, which apparently means the TWAIN protocol on Samsung devices, so this has something to do with scanning. (I have it connected as a network scanner too.)

EDIT 2: Using NetHogs, I found that colord-sane is sending packets. I also found this but there were no relevant answers as to how to disable this behavior. I will investigate further...

EDIT 3: I found two other questions on SE about this same problem: this and this. The only answer was to uninstall colord, which I may have to do.

EDIT 4: I renamed the colord service file. Fixed for now.

8
  • Where is the printer connected to in the network? how is your pc connected to the network? Where do you plug the usb device in (pc or printer)?
    – Michael D.
    Mar 12, 2017 at 21:56
  • PC is connected with Ethernet/CAT5e; printer with WiFi. This happens when I plug devices into the PC (back or front ports doesn't seem to matter).
    – user48147
    Mar 12, 2017 at 21:57
  • Both are connected directly to the gateway, there's a switch connected too but it's not in use.
    – user48147
    Mar 12, 2017 at 21:59
  • Is it possible to connect to your printers menu with your browser by entering the printers IP? Do you have wake up options there in the adminstrative tools?
    – Michael D.
    Mar 12, 2017 at 21:59
  • Yes, the printer includes the "SyncThru Web Service." I can change the length of time that the printer stays warmed up but not what actions cause it to wake up.
    – user48147
    Mar 12, 2017 at 22:04

1 Answer 1

0

The reason this happens is indeed related to colord-sane. When a device is added or removed, instead of processing only that device, colord-sane probes all SANE devices; this is equivalent to scanimage -L (which also wakes up remote multi-function printers).

The only way to disable this is currently to prevent colord-sane from running. One way to do that is to disable colord entirely; but a more focused approach is to delete colord-sane. I’ve filed an issue asking for colord-sane to be split out into its own pacakge; this would allow uninstalling only colord-sane. Until that happens, you’ll have to remember to delete colord-sane whenever colord is upgraded, or add a diversion using dpkg-divert so that it doesn’t get re-installed on upgrade.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .