1

If I try to open System Settings, nothing happens.

If I use the terminal, I get an error:

$cinnamon-settings
Traceback (most recent call last):
  File "/usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py", line 18, in <module>
gi.require_version('Gtk', '3.0')
AttributeError: 'module' object has no attribute 'require_version'
  • reinstalling mint fixed the issue. – John Stoneman Mar 13 '17 at 10:54
0

Try:

$ sudo apt-get install gir1.2-gtk-3.0 gir1.2-vte-2.91 python-gobject
$ sudo apt-get install --reinstall  --ignore-missing python-gobject

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.