2

Last week fedora 25 gnome software center installed a buggy gdm version on my system, I removed it but still having problems. I'm using Gdm and Wayland session.

I can't login to fedora from login page, the only way is to use tty, login, then startx

I tried many solutions, including removing Xauthority, chmod temp -R 755 or something and many other solutions but nothing worked.

What bother me the most is that I faced this same issue many years back on ubuntu and solved it but can't remember what I did! Hell I might have even solved it on Crunchbang many years ago!

the log file of startx

xauth:  file /home/user/.serverauth.1830 does not exist
X.Org X Server 1.19.1
Release Date: 2017-01-11
X Protocol Version 11, Revision 0
Build Operating System:  4.10.0-0.rc4.git0.2.fc26.x86_64 
Current Operating System: Linux fedora 4.9.13-201.fc25.x86_64 #1 SMP Tue Mar 7 23:47:11 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-4.9.13-201.fc25.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet LANG=en_US.UTF-8
Build Date: 01 February 2017  02:03:54AM
Build ID: xorg-x11-server 1.19.1-3.fc25 
Current version of pixman: 0.34.0
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/user/.local/share/xorg/Xorg.1.log", Time: Sun Mar 12 14:37:10 2017
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
(II) [KMS] Kernel modesetting enabled.
pkexec version 0.113

If it can't be solved, I'll switch to lightdm or kdm

6
  • Looks like related to unix.stackexchange.com/questions/350043/…
    – Jakuje
    Mar 13 '17 at 10:01
  • @Jakuje didn't work, just tried it. The log is still the same, unless you were referring to a different log then the one I'm showing in the question
    – Lynob
    Mar 14 '17 at 9:04
  • Do you see some SELinux AVCs in audit?
    – Jakuje
    Mar 14 '17 at 9:05
  • @Jakuje this? pastebin.com/hDTGnujZ
    – Lynob
    Mar 14 '17 at 9:14
  • First of all I would try with SELinux in permissive (setenforce 0).
    – Jakuje
    Mar 14 '17 at 9:19
1

type=AVC msg=audit(1489481742.902:140): avc: denied { view } for pid=1159 comm="gdm-session-wor" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:system_r:kernel_t:s0 tclass=key permissive=0

The AVC you posted points to this bug #1378297 already filled in the Red Hat bugzilla.

To make sure it is really the same problem, I would give it a try SELinux in permissive (running seteonfoce 0 will not be effective over reboots). Modify /etc/selinux/config and change enforcing to permissive and then try to reboot.

The other possibility is to follow the steps in the report:

# ausearch -c 'gdm-session-wor' --raw | audit2allow -M my-gdmsessionwor
# semodule -X 300 -i my-gdmsessionwor.pp

and reboot. If it will help, nagging in the bugzilla to fix that is probably a way to go :)

1
  • I changed that now to permissive, I even reinstalled gdm and gnome-shell, rebooted, same issue!
    – Lynob
    Mar 14 '17 at 9:40
0

I tried a billion solution, nothing worked, today I upgraded to Fedora 26, everything worked just fine, error fixed. No idea how, must be some buggy software that got fixed by the upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.