0

I'm trying to mount the home directory of the login node of the batch system at my office on my local machine using sshfs. However, when I run

export LOGLEVEL=DEBUG3
sshfs remotehostname:/user/myname $HOME/mounted/loginnodehome -o sshfs_debug

I just get this as an output:

SSHFS version 2.8

and then nothing. The command does not return, and I get no further output. I assume I have misconfigured something, but I really don't know what that could be, and I would need some hints as to where to start debugging this. Any suggestions?

Details: My home machine is running ArchLinux, the remote machine is running SLC6. Both use zsh as default shell. I have configured passwordless ssh using the standard PGP key method. I'm ready to provide further details on request.

  • 1
    Try ssh or sftp to the same remote host, with -v. That will probably hang in the same manner as sshfs and for the same reason, and it will be clearer what the problem is. – Celada Mar 12 '17 at 12:23
  • Simply using ssh on the same remote host works flawlessly. About sftp I don't know, I've never used it. Could you provide an example command line to test? – carsten Mar 12 '17 at 12:27
  • 1
    sftp remotehostname is the command to test. – Jakuje Mar 12 '17 at 12:35
  • sftp remotehostname hangs. Authentication seems to work, but using -v the last line is debug1: Sending subsystem: sftp – carsten Mar 12 '17 at 16:07
1

The problem is solved now. It was related to the authorized_keys file on the remote host, which read

command="/bin/zsh" id-rsa ...

Such that sftp andsshfs would try executing zsh upon login/authentication. Removing the command=... bit such that every line would start with id-rsa ... solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.