1

Why does my system boot stop at "Started WPA Supplicant"?

When I try to startup up my ArchLinux it pauses at "Started WPA supplicant" I had other problems which I solved like SDDM failure. And now everything shows OK. However the startup doesn't continue.

I've tried updating the system but it always fails.

  • Now I updated wpa_supplicant and it says The /etc/wpa_supplicant/wpa_supplicant.conf is file no longer managed by pacman and if it was modified, it has been renamed to wpa_supplicant.conf.pacsave. Move it to the original location of needed. – Charlie Plett Mar 12 '17 at 4:04
  • The startup screen also says failed to start Load/Save screen. – Charlie Plett Mar 12 '17 at 4:05
  • 1
    If everything shows OK, including that the machine started WPA supplicant, then your diagnosis that WPA Supplicant is faulty is clearly wrong. You need, as has already been said, to describe your system's actions more accurately than this. "it fails" is woefully inadequate, not least because there are two possible antecedents for the pronoun. People are not telepathic. – JdeBP Mar 12 '17 at 6:49
  • After running yaourt -Syua it shows error: failed to commit transaction (conflicting files) ttf-dejavu: /etc/fonts/conf.d/20-unhint-small-dejavu-sans-mono.conf exists in filesystem. – Charlie Plett Mar 12 '17 at 14:14
  • Now I removed ttf-dejavu and I will retry update. – Charlie Plett Mar 12 '17 at 14:17
0

A little more information would help a lot actually.. Did you recently install the wpa_supplicant package? Did you update your system recently? Is this a fresh install? Have you auto enabled a wifi profile lately? May something be wrong with that profile?

How long have you waited since the output on the screen says "Started WPA Supplicant" and did it actually go "success" and says "started" or "starting".. Is it still like that or did you turn it off?

Based on your other recent question here i assume you are running Arch Linux, would you be able to boot with the installation medium of Arch and chroot and disable/remove wpa_supplicant, and then try to boot your system again? Might be a broken package.. Have you checked bug tracker @ arch website?

Also, you could try to diagnose the hardware, (RAM and HDD) with Memtest and gsmartcontrol(smartmontools) (long shot, but still possible..)

I won't apologize for asking more questions than i replied with answers since your question is extremely vague.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.