2

What ever combination of "save" "save & apply" OpenWRT does not save any change, I stay at "change counter > 0" stage. Further more, clicking on the counter I see all the changes and when I click to commit them it seems to work but at the end nothing is performed, all changes are still undone.

reboot has no repair effect, even reloading the last "backup" does not fix the issue

The file status is as follows:

Filesystem           1K-blocks      Used Available Use% Mounted on
rootfs                     384       320        64  83% /
/dev/root                 2304      2304         0 100% /rom
tmpfs                    14368       524     13844   4% /tmp
/dev/mtdblock5             384       320        64  83% /overlay
overlayfs:/overlay         384       320        64  83% /
tmpfs                      512         0       512   0% /dev

/dev/root appears to be full, but I don't know how to reach it:

cd /dev/root

gives

-ash: cd: can't cd to /dev/root

I am still stuck, and seeking for knowledge or experience, on top I believe that the usual debian commands are not exactly what's needed for openWRT...

  • You should cd into /rom, as /dev/root is a device mounted under /rom. But I don't believe you need to. – ajeh Jun 21 '18 at 22:12
1

I had the same issue when there was 0 free space on /.

You can connect via ssh and run df to check how much free space is left:

$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
rootfs                     512       416        96  81% /

I had to go into /overlay/upper/usr/lib/opkg/ and manually delete some packages because opkg would not let me remove them.

1

/dev/root is your rom – it’s full and not writable. Your root directory is / and provides some space telling by the output. But even those numbers are not the space really available because it’s squashfs. See https://wiki.openwrt.org/doc/techref/flash.layout for further investigations

I am under the impression your problem is related to the gui. Maybe configuring via commandline is an option for you.

I am not sure what you mean by ”debian commands“ – you don’t have bash, it’s busybox afaik

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.