2

I just re-installed an updated version of an OS based on Debian Testing on my machine, but this time I booted the installation DVD as an UEFI(FAT) medium, so the OS was installed in UEFI-mode. I was going to modify my grub after installation, as usual, and noticed, that the os-prober didn't find my Windows 10 even though it found all other Linx OSes of different kinds, including UEFI and (!)NON-UEFI operating systems (NOTE: the operating system was missing BEFORE modification already). Every Linux works as expected and I don't have any problems with those. I just can't seem to find a way to add Windows 10 to the menu.

I searched a solution for quite a while now and some things are definitely clear:

  • ignoring non-UEFI systems by os-prober isn't the problem, because the other Linux systems are found, but not in UEFI mode
  • adding something to custom_40 or anything alike breaks the whole grub2 and I have to purge && re-install
  • Windows 10 has valid boot-entries, partition, etc, etc, because it worked before the re-installation of the aforementioned OS, and nothing has changed about the Windows 10 installation

I also found out through my research, that it might be connected to the fact that Windows 10 is installed on a different disk having the msdos partition table (MBR), while my Linux operating systems are on another identical disk, which is tabled as GPT, though.

So my question: how do I let GRUB2 find and add the Windows 10 entry on its own?

2
  • Does that win10 boot off that MBR partitioned drive under UEFI? Mixing those might be a nice headache recipe with buggy firmwares alone, adding windows to the mix might not make it any better... Commented Mar 13, 2017 at 10:36
  • 2
    Yes, in theory you are right. But in my experience, especially on my own rig, I barely had any issues with UEFI and its configuration. Even when mixing up those two. As partially implied, I had this HDD formatting constellation already before this happened. The difference is now that the OS responsible for the GRUB2 menu was installed as an UEFI system. I didn't think it'd become this big of a deal, since it worked before just fine. And still does to a certain degree. Just -who would've thought- Windows is f-ing around again...
    – Akito
    Commented Mar 13, 2017 at 10:54

1 Answer 1

2

I had the same problem and solved it by mounting the partition containing windows prior to executing os-prober

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .