0

I bought a second SSD to install Debain as a second OS on my Desktop (Win10 as primary OS). After installing Debian from a USB stick, when I start my PC I get a screen where I can choose what to boot (Debain / Windows / some memory tests). Windows still works fine, but when I choose Debian I see a few lines of text / code for a split second then the screen goes all black and nothing more happens.

The trial mode, where you can start Debian without installing it worked just fine, but when I tried installing Ubuntu before I had similar problems (when choosing the Ubuntu USB stick as boot medium I got a ubuntu loading screen then blackscreen without even getting to install it). After a few tries I managed to take a picture of the text:

Loading, please wait...

[ 0.563840][drm:radeon_pci_probe] ERROR radeon kernel modesetting for R600 or later requires firmware-linux-nonfree

So apparently it is a problem with my GPU (VTX3D AMD HD 7870 Black Edition) According to https://packages.debian.org/jessie/kernel/firmware-linux-nonfree firmware-linux-nonfree is a package that includes firmware for various stuff including GPUs. How can I get this package if I can't boot Debian?

Another less important question: When i'm on the screen where I can select what to boot it automatically boots Debian after 5 seconds if I don't do anything. Can I change the default to Windows / increase the time?

  • Can you boot in recovery mode? (In the boot menu, select “Advanced options for Debian GNU/Linux”, then the entry marked “recovery mode”. This should boot to a prompt asking you for the root password.) – Stephen Kitt Mar 10 '17 at 16:41
  • No, recovery mode leads to the same resualt as normal mode. – P. Duw Mar 10 '17 at 17:07
  • 1
    How about booting in recovery mode and disabling modesetting? You need to select the “recovery mode” option as above, but instead of hitting Enter, press E to enter edit mode, add radeon.modeset=0 at the end of the linux line (with a space to separate the new parameter from the last one), then press Ctrl+X to boot the modified entry. – Stephen Kitt Mar 10 '17 at 17:20
1

Try to boot debian in maintenance mode and disable the gpu driver and replace it with a generic one. And yes you can customize grub. Edit the config file /etc/default/grub and apply the changes by running grub-install with root privileges.

  • I tried to start in maintenance mode, but it doesn't boot either. Is there any way to disable and replace the gpu driver before the system needs to boot? – P. Duw Mar 10 '17 at 17:04
  • Take your gpu from your case(since you had desktop), boot and install the firmware for gpu, put gpu back and try to boot – Samelikameli Mar 10 '17 at 17:12
  • @Samelikameli the OP will have trouble doing that if the GPU is the only way to display anything! That would only work if there's another output (from an onboard GPU). – Stephen Kitt Mar 10 '17 at 17:13
  • I have an Intel HD4000 integrated with my CPU, so i'll try this too if the radeon.modeset=0-method from another comment doesn't help. I'll report back in about an hour whether one of them worked. – P. Duw Mar 10 '17 at 17:29
  • Neither of them worked. radeon.modeset=0 had no effect at all and unpluggig the GPU (only unplugged the cables and plugged a hdmi into the mainboard) led to a different error: FAILED Failed to start Store Sound Card State. See 'systemctl status alsa-store.service' for details. (I'm not 100% sure the error message is correct i had to make a video with my phone to be able to read it at all and the quality is really bad... – P. Duw Mar 10 '17 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.