0

I'm running Debian Jessie (stable) and I followed this method to install a single package from stretch (testing).

But I get an "unmet dependencies" error. How can I fix the issue and install the testing version of that package?

$ sudo apt-get -t stretch install libboost-all-dev

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gsettings-desktop-schemas : Breaks: gnome-settings-daemon (< 3.19.92) but 3.14.2-3 is to be installed
                             Breaks: mutter (< 3.19.92) but 3.14.4-1~deb8u1 is to be installed
 gstreamer1.0-plugins-base : Breaks: gstreamer1.0-plugins-bad (< 1.7.90) but 1.4.4-2.1+deb8u1 is to be installed
 libgstreamer-plugins-base1.0-0 : Breaks: gstreamer1.0-plugins-bad (< 1.7.1) but 1.4.4-2.1+deb8u1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
  • read this answer on askubuntu. – hyph Mar 10 '17 at 12:40
  • Did not make a diffference - there are no kept back dependencies as far as I can see. Also if I run sudo apt-get install libboost-all-dev (without the target version), everything works fine. – assylias Mar 10 '17 at 12:52
  • You will break your system , see the dependencies of gnome-settings-daemon – GAD3R Mar 10 '17 at 13:46
  • @GAD3R But I'm trying to install a recent version of boost, which has absolutely nothing to do with gnome... And I'm happy with the version of gnome that I have – assylias Mar 10 '17 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.