0

The /var partition is 100% full. The partition looks something like this:

rpool/ROOT/var 15G   3.4G    25M   100%    /var

1.4G   /var/adm/perfdata

I need to delete files from that folder, but I dont know what kind of files are. What type of files resides by default in /var/adm/perfdata folder? Can anyone offer information for this type of files? (I know that are DB related stuff)

1797 -rw-r--r--   1 root     root        775K Nov 11  2013 orcallator-2013-11-11-000.gz
1797 -rw-r--r--   1 root     root        775K Nov 12  2013 orcallator-2013-11-12-000.gz
1285 -rw-r--r--   1 root     root        605K Nov 13  2013 orcallator-2013-11-13-000.gz
 169 -rw-r--r--   1 root     root         84K Nov 13  2013 orcallator-2013-11-13-001
   1 -rw-r--r--   1 root     root           0 Nov 13  2013 orcallator-2013-11-13-002
   2 -rw-r--r--   1 root     root           5 May 22  2013 orcallator.pid

Do anyone have approach how to deal with that space problem(rpool/ROOT/var 15G 3.4G 25M 100% /var)? I solved something like this on Linux, but solaris doesn't have lsof tool.

  • plz can you give us the output of zfs list. – Hamza Jabbour Mar 10 '17 at 10:30
  • 2
    zfs list -t all would probably be better, since deleting files won't free any space if there are snapshots. Freeing space on a full ZFS file system can also be problematic - you can't delete the file because the copy-on-right nature of ZFS can require using extra space to do the deletion. – Andrew Henle Mar 10 '17 at 10:57
  • Ìt was a db problem. After I restarted the data base the problem solved. Thank you very much. – afl Mar 10 '17 at 14:53
1

Based on your listing, most of the files appear to be compressed, so this might not help long term, but you could try enabling compression on the dataset. It would also help keep usage down if other log files in /var/adm/ grew large by also being compressed.:

       `zfs set compress=on rpool/ROOT/var`

Since it's part of a pool, you could also allow the var dataset to use more storage.

Any snapshots to remove? zfs list -t all Old LUs to remove? lustatus

And on Solaris 10 and prior, and old patch backout data to remove? This will find any old patch backout data older than 3 years. Note:
- undo.Z files are backout. - obsolete.Z files are backout files for obe'd patches. - also grep'ing out IDR patches so that they can still be removed.

find /var/sadm/pkg -name '*.Z' -mtime +1068 | grep -v IDR > /var/tmp/patch_undo_files_to_clean.txt

Check out the file, and if it looks ok: df -h /var cat /var/tmp/patch_undo_files_to_clean.txt | xargs -n 2 /usr/bin/rm df -h /var

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.