1

When I boot my server, it shows the following and hangs forever:

[   88.166038] usb 2-1: device not accepting address 2, error -110
[   88.285980] usb 2-1: new high-speed USB device number 3 using ehci_hcd
[   93.423935] dracut Warning: No root device "block:/dev/disk/by-uuid/3be3a552-7f1e-42dc-b59d-c220cf349cd6" found
[  103.858270] usb 2-1: device not accepting address 3, error -110
[  103.978213] usb 2-1: new high-speed USB device number 4 using ehci_hcd
[  114.423040] usb 2-1: device not accepting address 4, error -110

From a recovery disk, I can see the disk just fine:

# blkid
/dev/sdm1: LABEL="/BOOT" UUID="7fd96db0-68b6-484f-96d4-bf65282160cd" TYPE="ext3"
/dev/sdm2: LABEL="/" UUID="3be3a552-7f1e-42dc-b59d-c220cf349cd6" TYPE="ext3"
# ls /dev/disk/by-uuid/3b*
/dev/disk/by-uuid/3be3a552-7f1e-42dc-b59d-c220cf349cd6

And my grub.conf looks like this:

timeout=5
default=0

title Linux (3.2.27-0.4.18.wd.0.31.231.metal1.x86_64)
    root (hd0,0)
    kernel /vmlinuz-3.2.27-0.4.18.wd.0.31.231.metal1.x86_64 ro root=UUID=3be3a552-7f1e-42dc-b59d-c220cf349cd6 nousb console=ttyS1,115200n8 earlyprintk=vga,keep
    initrd /initramfs-3.2.27-0.4.18.wd.0.31.231.metal1.x86_64.img

I've tried to drop into the dracut debug shell by adding the rdshell and rdinitdebug kernel params, but nothing seems to happen. Are there any alternative ways I can go about debugging? Any help is appreciated!

  • as per kernel.org/pub/linux/utils/boot/dracut/… rd.shell (note the .) drops into emergency shell if mounting fails. Looks like your machine doesn't stop trying to mount anyway, so you might be better off adding rd.break=pre-mount which should drop you into a shell before your ramdisk tries to mount the root partition. My guess is you'll need to rebuild your initrd to include some additional drivers/modules. – Centimane Mar 9 '17 at 18:52
  • Tried both of those, but I'm seeing the same behavior and hanging. I get a dracut warning with rd.break=pre-mount, but it never drops into a shell. At least I know I'm using the correct commands now. – user2963501 Mar 9 '17 at 19:49
  • rd.break= has more breakpoints, try something like rd.break=pre-trigger to try an earlier breakpoint. – Centimane Mar 9 '17 at 20:37
  • I should have said that, I tried pre-udev, pre-trigger, pre-mount. Going through the dracut docs now, I'll try them all and report back. – user2963501 Mar 9 '17 at 20:48
  • Nope, no go on any of those options. Oddly, rd.break=cmdline caused it to hang much earlier. Also combining rd.debug and rd.udev.debug got a few more lines of dracut warnings, and the host hung starting the plymouth daemon. – user2963501 Mar 9 '17 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.