I recently installed Linux Mint 18.1 to my MacBook Pro retina (on /dev/sda6) as I really liked it on the live USB. I had LM 17.3 on it and it worked fine. Anyway, after rebooting and starting up LM181, via rEFInd, I had not internet. I tried to install the driver/checkmark, but it complained about no internet. I even tried apt-cdrom --no-auto-detect --cdrom add but couldn't get it to work. I tried most of the ideas from here: https://askubuntu.com/questions/285539/detect-and-mount-devices . So this is only in case someone else has come across this problem with this recent distro.

So how do I get the wifi to work?


lspci -knn | grep Net -A2

x@x-MacBookPro ~ $ lspci -knn | grep Net -A2
03:00.0 Network controller [0280]: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)
  Subsystem: Apple Inc. BCM4360 802.11ac Wireless Network Adapter [106b:0134]
  Kernel driver in use: wl
  Kernel modules: bcma, wl
  • Welcome to U&L please edit here by adding the output of lspci -knn | grep Net -A2 – GAD3R Mar 9 '17 at 21:07

I'm sure there are much more technical and fancier ways. Maybe I should also have reported this bug(?) to Mint, but here is what I did to get wifi back.

I just mounted the .iso and installed the bcmwl deb file. It will complain about prerequisites, which were libc6 and its dev, and so those had to be installed first. By the way, when I say installed I just mean double click and the graphical deb installer will pop up and tell you in the top about prerequisites.

Then just updated it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.