I'm trying to get my Ubuntu box to run at a higher resolution than the default 1024x768. As you can see from the log, i'm using integrated Intel video drivers.

I've tried adding an xorg.conf with a dummy monitor but I still get the default resolution.

I've also tried specifying the geometry in the x11vnc.service.

Then I added a custom dummy monitor config, as below.


Section "Monitor"
    Identifier             "Monitor0"
    Option                 "Enable"  "true"
    Option                 "DPMS"    "false"
    DisplaySize            400   300

Section "Device"
    Identifier             "Device0"
    Driver                 "intel"

Section "Screen"
    Identifier             "Screen0"
    Device                 "Device0"
    Monitor                "Monitor0"
    DefaultDepth            24
    SubSection             "Display"
        Depth               24
        Modes              "1920x1080" "1600x1200" "1280x768"

File: /var/log/Xorg.0.log

[     3.564] (II) Module glx: vendor="X.Org Foundation"
[     3.564]    compiled for 1.18.4, module version = 1.0.0
[     3.564]    ABI class: X.Org Server Extension, version 9.0
[     3.564] (==) AIGLX enabled
[     3.564] (II) LoadModule: "intel"
[     3.565] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[     3.567] (II) Module intel: vendor="X.Org Foundation"
[     3.567]    compiled for 1.18.4, module version = 2.99.917
[     3.567]    Module class: X.Org Video Driver
[     3.567]    ABI class: X.Org Video Driver, version 20.0
[     3.567] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[     3.567] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[     3.567] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[     3.567] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[     3.570] (II) intel(0): Using Kernel Mode Setting driver: i915_bpo, version 1.6.0 20160425
[     3.570] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.2 (Timo Aaltonen <[email protected]>)
[     3.570] (II) intel(0): SNA compiled for use with valgrind
[     3.571] (--) intel(0): gen9 engineering sample
[     3.571] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2; using a maximum of 2 threads
[     3.571] (**) intel(0): Depth 24, (--) framebuffer bpp 32
[     3.571] (==) intel(0): RGB weight 888
[     3.571] (==) intel(0): Default visual is TrueColor
[     3.572] (II) intel(0): Output HDMI1 using monitor section Monitor0
[     3.572] (**) intel(0): Option "Enable" "true"
[     3.572] (II) intel(0): Enabled output HDMI1
[     3.572] (II) intel(0): Output HDMI2 has no monitor section
[     3.572] (II) intel(0): Enabled output HDMI2
[     3.572] (II) intel(0): Output DP1 has no monitor section
[     3.572] (II) intel(0): Enabled output DP1
[     3.572] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[     3.572] (II) intel(0): Output VIRTUAL1 has no monitor section
[     3.572] (II) intel(0): Enabled output VIRTUAL1
[     3.572] (==) intel(0): TearFree disabled
[     3.572] (**) intel(0): Display dimensions: (400, 300) mm
[     3.572] (**) intel(0): DPI set to (65, 65)
[     3.572] (II) Loading sub module "dri2"
[     3.572] (II) LoadModule: "dri2"
[     3.572] (II) Module "dri2" already built-in
[     3.572] (II) Loading sub module "present"
[     3.572] (II) LoadModule: "present"
[     3.572] (II) Module "present" already built-in
[     3.572] (==) Depth 24 pixmap format is 32 bpp
[     3.575] (II) intel(0): SNA initialized with Kabylake (gen9) backend
[     3.575] (==) intel(0): Backing store enabled
[     3.575] (==) intel(0): Silken mouse enabled
[     3.575] (II) intel(0): HW Cursor enabled
[     3.575] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[     3.576] (==) intel(0): Display hotplug detection enabled
[     3.576] (II) intel(0): [DRI2] Setup complete
[     3.576] (II) intel(0): [DRI2]   DRI driver: i965

^G Get Help       ^O Write Out      ^W Where Is       ^K Cut Text       ^J Justify        ^C Cur Pos        ^Y Prev Page      M-\ First Line    M-W WhereIs Next  ^^ Mark Text      M-} Indent Text   M-U Undo          ^B Back
^X Exit           ^R Read File      ^\ Replace        ^U Uncut Text     ^T To Spell       ^_ Go To Line     ^V Next Page      M-/ Last Line     M-] To Bracket    M-^ Copy Text     M-{ Unindent Text M-E Redo          ^F Forwards



ExecStart=/usr/bin/x11vnc -xkb -norc -forever -shared -display :0 -xrandr -auth guess -rfbauth /etc/x11vnc.pass -localhost -o /var/log/x11vnc.log
ExecStop=/usr/bin/killall x11vnc

  • Try using a frame buffer instead of a dummy monitor. xrandr -fb 1680x1050 Must be setup before x11vnc is started.
    – jc__
    Mar 24, 2017 at 18:47

2 Answers 2


I've been using this approach:

FD_GEOM=1920x500 FD_SESS=xfce x11vnc -create

The environmental variables FD_GEOM and FD_SESS are used if no existing display can be found. "-create" will look for one and create one virtual one otherwise.

There is a good section on man x11vnc on creating displays that should help you out further:

You can set the environment variable FD_GEOM (or X11VNC_CREATE_GEOM) to WxH or WxHxD to set the width and height and optionally the color depth of the created display. You can also set FD_SESS to be the session (short name of the windowmanager: kde, gnome, twm, failsafe, etc.). FD_OPTS contains extra options to pass to the X server. You can also set FD_PROG to be the full path to the session/windowmanager program.


Using an Ubuntu 14 (64bit) machine with LXDE and LXDM, I was able to start x11vnc before user log in with no keyboard or monitor connected.

By setting a frame buffer with xrandr the vnc had the screen resolution of the frame buffer.

In /etc/lxdm/LoginReady I added the 2 lines:

xrandr --fb 1580x950
/usr/bin/x11vnc -nevershared -noxdamage -forever -localhost -nopw -threads -bg -auth /var/run/lightdm/root/:0 -display :0 -rfbport 5900 -o /var/log/x11vnc.log &

This may give you a starting point.

  • How are you connecting to this machine?
    – jc__
    Mar 24, 2017 at 19:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .