3

I run a fedora x86_64 within virtualbox. The host is windows 10. After I made a (quite a few times actually) fresh new install of fedora workstation 25, I install a few things

#dnf group install "Development Tools"
#dnf update

install guest additions (but not consistent)

and I reboot : I end up at the login screen like so :enter image description here

When I click on my login, it fails to login (like, screen goes black and return to this state) Same happens when I login typing the account name. nb : I can log-in before updating. I can however log-in in another tty (through terminal mode). (root graphical not working as well.)

The journalctl of a reboot + try to log graphically can be read here :

journalctl -b-0 | fpaste 

fpaste result

There seem to be some failure associated with gnome session desktop.

I tried to install kde, cinnamon, mate, sugar to be able to switch to another desktop manager, but I can't find any option to do so in the login screen, like I read I should.

I nevertheless found

/etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/gdm.service

but I can't find any other that I previously installed in here (I found some service in /usr/share/dbus-1/system-services/, but I don't know whether or not it is pertinent.)

Any idea on how I can successfuly repair that stuff ?

Possible duplicate (without answers) : Fedora 25: GNOME problem with logging back in

Quick update : Now a quick

#dnf update

seem to have resolve the trick a few days after anyway.

1

mars 08 18:06:01 localhost.localdomain audit[1386]: AVC avc: denied { execute } for pid=1386 comm="gnome-shell" path=2F7661722F6C69622F67646D2F2331333131313636202864656C6574656429 dev="dm-0" ino=1311166 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=file permissive=0

This is SELinux AVC message preventing to execute some file in the /var/lib, which is not allowed by the policy. There is related bug.

There are several things you can do about that. The easiest is to try again with SELinux in permissive mode (temporarily)

setenforce 0

If it is just throw-away virtual machine it should be ok. Otherwise, keep an eye on the logs if there will show up something new after the change.

0

You can select Gnome-Xorg at logging in. When logged in just run

gnome-shell --mode=user -r &

in the Terminal to start Gnome

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.