1

When exporting Libreoffice Draw as a .png file, it offers the choice of exporting using transparency. However, this option does not seem to work at all on the exported image. Is it a bug, or do we need to do something extra? It would be a very nice feature to get working.

7
  • When the background of the pages is set to "none" it should work.
    – ridgy
    Commented Mar 8, 2017 at 15:28
  • I'm not familiar with this option. Where do I edit the background?
    – uuuwantnan
    Commented Mar 8, 2017 at 15:56
  • Right click on the page and in context menu select page->page setup. Or from the main menu, select Format->Page/Slide Properties. In tab background set "Fill" to "none".
    – ridgy
    Commented Mar 8, 2017 at 16:02
  • i see. well i have checked and it was already set to none. so i think there must be something else for the transparency to be enabled.
    – uuuwantnan
    Commented Mar 8, 2017 at 16:07
  • How did you check transparency? Does display <file.png> not show the gray squared background?
    – ridgy
    Commented Mar 8, 2017 at 16:09

1 Answer 1

1

In LibreOffice Impress...

CLICK Slide | Master Background Set Slide Background --> "None"

Export the slide to an image format that supports an Alpha channel. .png is a common one.

FILE | Export | choose "PNG - Portable Network Graphic (.png)"

In the export menu verify that "Save Transparency" is enabled with a check mark.

Browse for and open the image in an image viewer such as Ristretto.

The background should be checkerboard of light and dark grey squares. This denotes the alpha channel (transparent part)

This is very useful for making titles for videos. I set the aspect ratio of the slide the same as the video. E.g. 1920 X 1080. I then create the title text with my preferred font, etc. Then after exporting I can overlay the image over my video track and the text nicely overlays the video without having to mess around with color keying.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .