1

I am using Debian jessie, with an xfce desktop environment. I managed to type in English, Greek, Russian and Arabic and to toggle between them by using the

setxkbmap

command in the

.bashrc

file. I also set the Compose key to lwin, so using the left windows key I could type an e with e.g. an accent aigu, grave of circonflexe for e.g. French words.

Since I also need to type in Chinese using pinyin, I did some research and installed ibus with the necessary packages. Now I am using both at the same time, and when the language icon representing the setxkbmap setting is on US, IBus works and I can toggle between English and Chinese using Shift, like I was used to when I was working on Windows.

But now when I'm typing English, I cannot use the compose key anymore. Any tips on this?

  • Looks like this is a terrible site for Debian users... I'm sorry. – Rodrigo Apr 19 '17 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.