I'm trying to get my scanner/printer Canon PIXMA MG3550 to work over the network with XSane. The driver is installed and almost everything works (printing over USB & network, scanning over USB).

The scanner is recognized, XSane's info panel shows correct information about the device, so does scanimage -L which returns

device `pixma:MG3500_192.168.xx.yy' is a CANON Canon PIXMA MG3500 Series multi-function peripheral

But when I hit the scan button in XSane I get the following error :

Error during read: Error during device I/O

Yet the scanner seems to respond when I click on scan or preview since I can hear the hardware briefly move before I get the error.

I'm running Debian Jessie. (I don't know where to look for XSane error log...)

Any suggestions ?

Edit 1 : I installed scangearmp which is the soft provided by Canon and it works flawlessly.
I don't know why but previewing with XSane worked 2 or 3 times in an unpredictable way although I'm totally unable to reproduce this on purpose. At first I thought that deleting ~/.sane was the trick but after checking again several times I can confirm it is not.


Exactly the same in my case (including what edit 1 reports) on Ubuntu 18.10, amd64 machine, Pixma MG3650.



[... blah blah...] 
[pixma] pixma_read_image() failed ETIMEDOUT
[pixma] Reader task terminated: ETIMEDOUT
[pixma] read_image():reader task closed the pipe:195228 bytes received, 1678578 bytes expected
sane_read= 9 = Error during device I/O
[pixma] pixma_close(): Canon PIXMA MG3600 Series

Therefore I increased the timeout setting in the configuration file:

  1. As a precaution so you can reverse the following if it doesn't work, make a backup copy of /etc/sane.d/pixma.conf:

    $ sudo cp /etc/sane.d/pixma.conf  /etc/sane.d/BACKUPpixma.conf 
  2. To increase the timeout, open /etc/sane.d/pixma.conf and uncomment line 21; i.e., delete the leading hash ('#') sign so as to change #bjnp-timeout=5000 to: bjnp-timeout=5000.

  3. Save the modified file.

  4. Test with Skanlite, gscan2pdf, XSane or other sane-based programme(s) of your choice.

Not sure this is the only solution or the best – better ideas welcome. If it didn't work, you can undo it by:

$ sudo cp /etc/sane.d/BACKUPpixma.conf  /etc/sane.d/pixma.conf
  • I'm on Ubuntu 18.04 right now. I used Simple Scan until now because it works for me :). I've just installed XSane and it worked without modifying pixma.conf. I can't reproduce the error... Sometimes just wait for updates I guess :). But your solution is interesting, plus you got the error on Ubuntu 18.10, strange... I'm glad it worked for you and hope it will be useful for others facing this error. – McQuack Jan 25 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.